Closed Bug 913419 Opened 7 years ago Closed 6 years ago

Black spots appearing on page while scrolling

Categories

(Core :: Graphics, defect)

26 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: passcod, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130905030206

Steps to reproduce:

Browse normally, and scroll down pages.


Actual results:

Sometimes, upon scrolling (the effect is seemingly random, although it tends to happen in loose clusters), black spots (rectangles of 3x6 pixels) appear on the page.

- This does not happen on chrome.
- A spot disappears when it scrolls out of view or when it "hits" position:fixed elements on the page.
- Spots only appear while scrolling, never when stationary.
- All spots disappear when the window loses focus, e.g. when alt-tabbing or changing workspace or clicking another application. (This makes them quite hard to capture.)

Reproduced: (and with combinations of the below)

- on Firefox 26.0a1 (2013-09-05)
- on Firefox 23.0.1
- in safe mode
- with a clean profile
- with hardware acceleration disabled

Graphics:

Adapter Description:	Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
Device ID:	Mesa DRI Intel(R) Ivybridge Mobile
Driver Version:	3.0 Mesa 9.2.0
GPU Accelerated Windows:	0/1 Basic
Vendor ID:	Intel Open Source Technology Center
WebGL Renderer:	Intel Open Source Technology Center -- Mesa DRI Intel(R) Ivybridge Mobile
windowLayerManagerRemote:	false
AzureCanvasBackend:	cairo
AzureContentBackend:	none
AzureFallbackCanvasBackend:	none
AzureSkiaAccelerated:	0




Expected results:

No spots should appear on the page!
Component: Untriaged → Graphics
Product: Firefox → Core
See Also: → 913388
I have this issue too. Seems like it is related to the XF86 Intel video driver: https://bugs.freedesktop.org/show_bug.cgi?id=68410

This happens on random pages.
Hi
Happened to me too on Firefox 25, both on Arch linux and Gentoo.
On Intel graphics and x64 Intel Haswell
However - _other browser works fine_, tested Epiphany.

I can help with some testing/debugging if needed
Yay, I have the same bug with FireFox 32 on Gentoo Linux. I'm also using a system with Intel graphics. I would suspect it's either a bug in the Intel driver or a Mesa problem.
The issue seems to be Intel driver related. Here is a discussion of the issue including some workarounds: https://bbs.archlinux.org/viewtopic.php?id=169449
Issue disappeared after upgrading the Intel driver to 2.99.916
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.