Support a model for roles and permissions

RESOLVED DUPLICATE of bug 757245

Status

Mozilla Developer Network
User management
RESOLVED DUPLICATE of bug 757245
4 years ago
4 years ago

People

(Reporter: Janet Swisher, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
Based on this discussion (https://groups.google.com/forum/#!topic/mozilla.mdn.drivers/TA79fWQ7Ifo), provide support for a model of roles and permissions similar to the following:

* Anonymous (not logged in)
** read pages
** launch demos
** like demos

* Authenticated (logged in)
** create pages
** edit pages and tags
** move single pages
** create demos
** modify own demos
** revert pages

* Trusted user (trusted for potentially destructive actions)
** delete pages
** move multiple pages
** edit templates

* Admin (trusted to do anything)
** ban users
** change user roles
** purge pages

Note that we might eventually want multiple levels or types of non-admin trusted users.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 757245
You need to log in before you can comment on or make changes to this bug.