Crash under mozilla::dom::CanvasRenderingContext2D::Restore()

RESOLVED DUPLICATE of bug 903722

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 903722
5 years ago
5 years ago

People

(Reporter: till, Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Shumway:P1])

(Reporter)

Description

5 years ago
STR:
1. With the current Nightly, visit http://www.areweflashyet.com/shumway/examples/inspector/inspector.html?rfile=http://swf.codeazur.com.br/archive/84/17/4e/4d/84174e4d43ace16041be3c2e668d27f25e87a78514e9c6064fa0ecef3ed30bdc.swf
3. wait until some vector image with a cat and the word "Start" is displayed
2. click on "Start"


Backtrace:
* thread #1: tid = 0x1d03, 0x00007fff952a7212 libsystem_kernel.dylib`__pthread_kill + 10, stop reason = signal SIGABRT
    frame #0: 0x00007fff952a7212 libsystem_kernel.dylib`__pthread_kill + 10
    frame #1: 0x00007fff90fccb54 libsystem_c.dylib`pthread_kill + 90
    frame #2: 0x00007fff91010dce libsystem_c.dylib`abort + 143
    frame #3: 0x00007fff91011e2a libsystem_c.dylib`__assert_rtn + 146
    frame #4: 0x00007fff974eeb78 CoreGraphics`CGGStackRestore + 145
    frame #5: 0x00007fff974eeabe CoreGraphics`CGContextRestoreGState + 32
    frame #6: 0x0000000101a0c7a0 XUL`mozilla::dom::CanvasRenderingContext2D::Restore() + 192
    frame #7: 0x00000001025cedf1 XUL`mozilla::dom::CanvasRenderingContext2DBinding::restore(JSContext*, JS::Handle<JSObject*>, mozilla::dom::CanvasRenderingContext2D*, JSJitMethodCallArgs const&) + 17
    frame #8: 0x000000010fa16373

Doesn't trigger the crash reporter and doesn't leave an entry in about:crashes
(Reporter)

Comment 1

5 years ago
Ah, Yury tells me this got fixed yesterday. Most lovely.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903722
You need to log in before you can comment on or make changes to this bug.