Closed Bug 91357 Opened 19 years ago Closed 18 years ago

redhat.com - Uses <DIV>s for left/right sidebar/content, but renders top/bottom

Categories

(Tech Evangelism Graveyard :: English US, defect, P1)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kbh7, Assigned: bc)

References

()

Details

(Whiteboard: [XBROWSER-CSS][aok])

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2+) Gecko/20010715
BuildID:    2001071521

The Mauve web site has a 2-finger-wide sidebar-like panel
on the left side, and content to the right of that, like
many web pages.  Under Mozilla, the content (right side)
renders under the sidebar, not to the right of it -- you
have to scroll down to see it.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla
2. Go to http://sources.redhat.com/mauve/
3. Scroll down to see the content

Actual Results:  Must scroll down to read most of the content

Expected Results:  Content should appear to the right of the sidebar,
no scrolling required.

Netscape 4.77 renders this.  (I don't know if it's "correct"
or not, but 4.77's is probably the intended rendering.)
Over to evangelism.

The stylesheet has:

DIV.sidebar { 
            position: float;
            background-image: url(img/sidebar.gif);
            background-repeat: no-repeat;
            background-position: left top;
            float: left;
            width: 110px;
            height: 600px;
            margin-left: 0px;
            border-left: 0px;
            padding-top: 12px;
            padding-left: 0px;
            border-width: 0;
                                       }

DIV.content {
            position: float;
            float: right;
            padding-top: 12px;
            padding-left: 20px;
            overflow: hidden;
            border-width: 0; 
            text-align: left;            
                                       }

Note the lack of a width for the div#content.  Floated boxes _must_ have a width
set...  In this case, the width defaults to the width of the page, and the two
floated boxes don't fit next to each other.
Assignee: karnaze → bclary
Status: UNCONFIRMED → NEW
Component: Layout → Evangelism
Ever confirmed: true
QA Contact: petersen → zach
Whiteboard: [XBROWSER-CSS]
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Priority: -- → P1
Summary: Uses <DIV>s for left/right sidebar/content, but renders top/bottom → redhat.com - Uses <DIV>s for left/right sidebar/content, but renders top/bottom
page design by http://freehive.styx.net/ which is dead, jim.

Whiteboard: [XBROWSER-CSS] → [XBROWSER-CSS][aok]
contacted
Status: NEW → ASSIGNED
Target Milestone: --- → Apr
-> fixed.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.