hwc_layer mismatch between hwcomposer.h from hardware/ and gonk/

RESOLVED DUPLICATE of bug 912090

Status

()

RESOLVED DUPLICATE of bug 912090
5 years ago
5 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
We've got a copy of hwcomposer in widget/gonk/hardware/hwcomposer.h and in hardware/libhardware/include/hardware/hwcomposer.h but hwc_layer is different causing to nasty rendering bugs.

Specifically the extra alpha fields causes the displayFrame fields to be shifted by sizeof(int32_t) which causes a nonsensical layer dimensions that aborting drawing.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912090
You need to log in before you can comment on or make changes to this bug.