All users were logged out of Bugzilla on October 13th, 2018

nsSupportsArray needs to be rewritten

RESOLVED DUPLICATE of bug 166888

Status

()

RESOLVED DUPLICATE of bug 166888
18 years ago
13 years ago

People

(Reporter: kandrot, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Based on bug 82133.  This class needs to be rewritten, to be cleaner, and use
XPCOM.  All accessing code will need to be changed as well, which looks to be a
fair amount.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

17 years ago
reassign all kandrot xpcom bug.
Assignee: kandrot → dougt
Status: ASSIGNED → NEW

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Keywords: mozilla1.0

Comment 2

17 years ago
nsSupportArray is not part of the mozilla 1.0 api freeze.
Target Milestone: mozilla1.0 → Future
nsSupportsArray should be killed and replaced by nsArray. See bug 166888
It looks to me like this should be WONTFIX/INVALID, per comment 3.
Assignee: dougt → nobody
QA Contact: scc → xpcom

*** This bug has been marked as a duplicate of 166888 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.