Closed Bug 913627 Opened 6 years ago Closed 6 years ago

Update androidx86.json for x86 emu mochitests

Categories

(Testing :: Mochitest, defect)

x86
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #902160 +++

Since updating androidx86.json about a month ago, some additional tests have started failing on x86 only. 

To get a clean x86 run, I want to disable a few more tests.
Attached patch wip (obsolete) — Splinter Review
Filed bug 913662 and bug 914439 to follow-up on the most common failures.
Attachment #800970 - Attachment is obsolete: true
Attachment #801959 - Flags: review?(jmaher)
Comment on attachment 801959 [details] [diff] [review]
update androidx86.json

Review of attachment 801959 [details] [diff] [review]:
-----------------------------------------------------------------

that is a lot of files we are skipping now.  Is that related to running in the emulator vs a device?

::: testing/mochitest/androidx86.json
@@ +68,5 @@
> + "content/canvas/test/test_2d.composite.image.source-out.html": "x86 only bug 913662",
> + "content/canvas/test/test_2d.composite.uncovered.image.destination-atop.html": "x86 only bug 913662",
> + "content/canvas/test/test_2d.composite.uncovered.image.destination-in.html": "x86 only bug 913662",
> + "content/canvas/test/test_2d.composite.uncovered.image.source-in.html": "x86 only bug 913662",
> + "content/canvas/test/test_2d.composite.uncovered.image.source-out.html": "x86 only bug 913662",

fyi, these test_2d tests will be moving into a subharness, so this will eventually turn into a single line item :)
Attachment #801959 - Flags: review?(jmaher) → review+
(In reply to Joel Maher (:jmaher) from comment #5)
> that is a lot of files we are skipping now.  Is that related to running in
> the emulator vs a device?

I do not think they are related to emulator vs device. None of these were failing just a few weeks ago. I am hoping all of the failures are related to bug 913662 and bug 914439.
https://hg.mozilla.org/mozilla-central/rev/074ec56640f6
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
We have found more M3 media tests that crash -- skipped here.
Attachment #805999 - Flags: review?(jmaher)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 805999 [details] [diff] [review]
disable a few more media tests on x86

Review of attachment 805999 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for documenting the bugs associated with these skipped tests.
Attachment #805999 - Flags: review?(jmaher) → review+
Most of these were just disabled via bug 899420! The remainder:

https://hg.mozilla.org/integration/mozilla-inbound/rev/9124687e1aa1
Once this merges to m-c we should merge m-c to Cedar and see them clear up.
https://hg.mozilla.org/mozilla-central/rev/9124687e1aa1
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: mozilla26 → mozilla27
Blocks: 936226
You need to log in before you can comment on or make changes to this bug.