Replicate Popcorn Maker's options menu

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: brett, Assigned: pomax)

Tracking

Details

(Whiteboard: mozfest)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Popcorn Maker now has improved drop downs that:
-Place logout and MyMakes under the user dropdown
-Place delete and new project in an options menu

We should replicate this in Thimble
(Assignee)

Comment 1

5 years ago
Created attachment 804568 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/215

replicates the popcorn user bar, currently only with "new" as option. "delete" should be a followup, since we don't have delete right now in thimble either.
Attachment #804568 - Flags: review?(schranz.m)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 904035
(Assignee)

Comment 3

5 years ago
Comment on attachment 804568 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/215

note that the parachute code is commented off right now, in case of problems. If this works correctly, r- me and I'll remove them entirely (As well as the parachute.js file).

(Note: the .less files are straight from popcorn, you can probably ignore those, too)
Comment on attachment 804568 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/215

One functionality problem.

STR:
1) Sign in.
2) Select My Makes.
3) Close My Makes.
4) Logout
5) Login

Expected: Normal UI is shown. My Makes is closed.
Actual: My Makes is open.

There's definitely a whole crap tonne of bloated CSS styles that aren't being used here from PM. Plus the whole odd name spacing of "butter-" when we are Thimble, but with the idea of making it a bower component I'd consider looking past that.
Attachment #804568 - Flags: review?(schranz.m) → review-
(Assignee)

Comment 5

5 years ago
nice find, I'll have a look at why it's doing that. Also, yeah, I'm not too keen on doing lots of weeding if we want to turn this into a self-contained module. The "butter" namespacing is quirky, but I'd rather not start renaming all the file content atm. If anything, being namespaced to a different project means that a refactor to something not-thimble, not-butter will still work since it's working with not-thimble namespacing atm.
(Assignee)

Updated

5 years ago
Depends on: 916371
(Assignee)

Comment 6

5 years ago
turns out that bug is in production right now, and not actually part of this patch. hurray! also "gah", so have a second PR.

If we discount that bug for this ticket, anything else other than "cleanup" that should be fixed?
(Assignee)

Updated

5 years ago
Attachment #804568 - Flags: review- → review?
(Assignee)

Updated

5 years ago
Attachment #804568 - Flags: review? → review?(schranz.m)
Comment on attachment 804568 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/215

One comment.

I don't know what the parachute stuff was doing before, but it appears functional to me without it. Looks like that code can be removed.
Attachment #804568 - Flags: review?(schranz.m) → review-
(Assignee)

Comment 8

5 years ago
It was the code responsible for making sure that if you opened thimble.webmaker.org, the previous session's code was "recovered", even if it was in a new tab or window. Keeping that in would completely negate the idea of starting a "new" document, as it would open a new tab/window for thimble.webmaker.org and then immediate swap the new-page-code for the code you already had in your old tab.
(Assignee)

Comment 9

5 years ago
Comment on attachment 804568 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/215

removed parachute code and farbtastic, also fixed an issue with the new user signup panel having the wrong z-index (it would "show" underneath friendlycode)
Attachment #804568 - Flags: review- → review?(schranz.m)
Attachment #804568 - Flags: review?(schranz.m) → review+
(Assignee)

Comment 11

5 years ago
landed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 920162
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.