If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][SMS]When receive an SMS during handset locked,there is no notification

RESOLVED FIXED in Firefox 26, Firefox OS v1.1hd

Status

()

Core
DOM: Device Interfaces
P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: Gene Lian (I already quit Mozilla))

Tracking

unspecified
mozilla26
Points:
---

Firefox Tracking Flags

(blocking-b2g:leo+, firefox24 wontfix, firefox25 wontfix, firefox26 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed, b2g-v1.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Firefox os  v1.1
  Mozilla build ID:20130902041201
 
 +++ This bug was initially created as a clone of Bug #501985 +++
 DEFECT DESCRIPTION:
  When receive an SMS during handset locked,there is no notification
  REPRODUCING PROCEDURES:
  1.Not plugin usb.
  2.Close SMS App in background.
  3.Receive an SMS when handset locked,there is no notification->KO1
  4.Press power key,the notification and alert comes->KO2
 
  EXPECTED BEHAVIOUR:
  When you receive SMS,it should have notification.
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Mid
  REPRODUCING RATE:
  4/5
  For FT PR, Please list reference mobile's behavior:
 ++++++++++ end of initial bug #501985 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Updated

4 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 801098 [details]
logcat
Updating to correct component.
Component: Gaia::SMS → Gaia::System
probably a dupe of bug 875703
Flags: needinfo?(gene.lian)
(Assignee)

Comment 5

4 years ago
Exactly... Let me take this and give it a full test again. It seems a very tricky random bug.
Assignee: nobody → gene.lian
Flags: needinfo?(gene.lian)
(Assignee)

Comment 6

4 years ago
Created attachment 801590 [details] [diff] [review]
Patch
Attachment #801590 - Flags: feedback?(vyang)
Component: Gaia::System → DOM: Device Interfaces
Product: Boot2Gecko → Core
Comment on attachment 801590 [details] [diff] [review]
Patch

Review of attachment 801590 [details] [diff] [review]:
-----------------------------------------------------------------

Just like the cpu lock we have for call ring events.
Attachment #801590 - Flags: feedback?(vyang) → feedback+
(Assignee)

Updated

4 years ago
Flags: needinfo?(jcheng)
(Assignee)

Comment 8

4 years ago
Created attachment 802315 [details] [diff] [review]
Patch, V2
Attachment #801590 - Attachment is obsolete: true
Attachment #802315 - Flags: review?(vyang)
Attachment #802315 - Flags: review?(vyang) → review+
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/0e994d38fb3d

Hi Joe, need your decision to mark leo+ or not.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 875703
https://hg.mozilla.org/mozilla-central/rev/0e994d38fb3d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Duplicate of this bug: 915114
Why can't this wait for 1.2?
blocking-b2g: leo? → koi?
Preeti> I think Gene wanted this in leo because this is annoying and we had actually real user reports about that.

However, playing with Wakelock is risky for the user's battery and it's maybe a good idea to keep it for 1.2.

So it's your call :)

Comment 15

4 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #13)
> Why can't this wait for 1.2?

When receive a SMS during handset locked, there is no notification. And then user will not know the new sms coming timely, and may not reply to the sms sender. It is so annoying.
(In reply to Preeti Raghunath(:Preeti) from comment #13)
> Why can't this wait for 1.2?

This actually caused me real trouble.  Really bad behavior of the phone.
Renominating leo after comment 14 15 and 16.
blocking-b2g: koi? → leo?
No SMS notifications on the lock screen is a blocker.
blocking-b2g: leo? → leo+
https://hg.mozilla.org/releases/mozilla-b2g18/rev/725c2992dac6
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
status-b2g-v1.2: --- → fixed
status-firefox24: --- → wontfix
status-firefox25: --- → wontfix
status-firefox26: --- → fixed
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/725c2992dac6
status-b2g-v1.1hd: affected → fixed
(Assignee)

Comment 21

4 years ago
Thanks Ryan for the manual merge which looks good to me.
Flags: needinfo?(jcheng)
You need to log in before you can comment on or make changes to this bug.