Charset override or auto-detector is not applied to vCard attachment

VERIFIED DUPLICATE of bug 91383

Status

VERIFIED DUPLICATE of bug 91383
17 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 07/18 win32 branch build.

When a vCard file is received as an attachment, charset override or
auto-detector is not applied to the attachment display.

Steps to reproduce:
1. Have a vCard file containing Ja data in your local drive.
2. Compose a mail with this vCard attached and send out the mail in ISO-2022-JP.
3. After the mail is received, the vCard attachment is displayed garbled.
Selecting the proper charset menu or setting proper folder charset doesn't
correct the display. Turn on the auto-detector for Japanese doesn't correct the
display either.
If you open the message source for this mail, you can see the content type is
"text/x-vcard"

I'll attach a testing mail later.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 91383 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Marked it as verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.