Filtering IonSpew with IONFILTER env var broken

RESOLVED FIXED in mozilla27

Status

()

Core
JavaScript Engine
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Yves Gwerder, Assigned: Yves Gwerder)

Tracking

Trunk
mozilla27
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 801143 [details] [diff] [review]
IONFILTER_fix.diff

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130803192641

Steps to reproduce:

Set the IONFILTER environment variable to a specific function using export IONFILTER=filename.js:1234.




Actual results:

IonSpew won't output anything even though the function is Ion compiled.


Expected results:

Ion.cfg and Ion.json in /tmp should contain data for the SSA graphs.
(Assignee)

Comment 1

4 years ago
The reason for this issue is that the static keyword is used for the filelen (check the attached patch).
It will always contain the first value assigned but it should contain the length of the current filename.
Comment on attachment 801143 [details] [diff] [review]
IONFILTER_fix.diff

Review of attachment 801143 [details] [diff] [review]:
-----------------------------------------------------------------

Nice find
Attachment #801143 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/17abba1ddb3f

Thanks for the patch, Yves! One request, please make sure that you configure Hg to generate patches will all the needed metadata for checkin. Makes life easier for those landing on your behalf. Thanks!
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/17abba1ddb3f
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27

Updated

4 years ago
Assignee: general → yves.gwerder
You need to log in before you can comment on or make changes to this bug.