Build fails when building with GTK3

RESOLVED INVALID

Status

()

Core
Build Config
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Elad Alfassa, Unassigned)

Tracking

23 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130903162920

Steps to reproduce:

clone mozilla-central,
echo ac_add_options --enable-application=browser > .mozconfig
echo ac_add_options --enable-default-toolkit=cairo-gtk3 >> .mozconfig
echo ac_add_options --disable-tests >> .mozconfig
./mach configure
./mach build


Actual results:

Build failed, 

 0:47.38 
 0:47.38 In the directory  /home/elad/sources/firefox/obj-x86_64-unknown-linux-gnu/widget/gtk2
 0:47.38 The following command failed to execute properly:
 0:47.38 c++ -o nsWindow.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /home/elad/sources/firefox/config/gcc_hidden.h -DNATIVE_THEME_SUPPORT -DMOZ_GLUE_IN_PROGRAM -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DSTATIC_EXPORTABLE_JS_API -DNO_NSPR_10_SUPPORT -DOS_POSIX=1 -DOS_LINUX=1 -DCAIRO_GFX -DMOZ_APP_NAME="firefox" -I/home/elad/sources/firefox/ipc/chromium/src -I/home/elad/sources/firefox/ipc/glue -I../../ipc/ipdl/_ipdlheaders -I/home/elad/sources/firefox/widget/gtk2 -I. -I../../dist/include -I/home/elad/sources/firefox/obj-x86_64-unknown-linux-gnu/dist/include/nspr -I/home/elad/sources/firefox/obj-x86_64-unknown-linux-gnu/dist/include/nss -I/home/elad/sources/firefox/widget/gtk2/../xpwidgets -I/home/elad/sources/firefox/widget/gtk2/../shared -I/home/elad/sources/firefox/layout/generic -I/home/elad/sources/firefox/layout/xul/base/src -I/home/elad/sources/firefox/other-licenses/atk-1.0 -I/home/elad/sources/firefox/widget/gtk2/../shared/x11 -fPIC -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/nsWindow.o.pp -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -Os -freorder-blocks -fomit-frame-pointer -I/home/elad/sources/firefox/obj-x86_64-unknown-linux-gnu/dist/include/cairo -pthread -I/usr/include/gtk-3.0/unix-print -I/usr/include/gtk-3.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libdrm -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include /home/elad/sources/firefox/widget/gtk2/nsWindow.cpp
 0:47.38 gmake[6]: *** [nsWindow.o] Error 1
 0:47.38 gmake[5]: *** [libs] Error 2
 0:47.38 gmake[4]: *** [libs_tier_platform] Error 2
 0:47.38 gmake[3]: *** [tier_platform] Error 2
 0:47.39 gmake[2]: *** [default] Error 2
 0:47.39 gmake[1]: *** [realbuild] Error 2
 0:47.39 gmake: *** [build] Error 2

running the command manually produced the following output:
<command-line>:0:0: internal compiler error: Segmentation fault

GCC version: c++ (GCC) 4.8.1 20130603 (Red Hat 4.8.1-1)



Expected results:

Build should succeed.

Updated

4 years ago
Component: Untriaged → Build Config
Anybody tried building with gcc 4.8 yet?
Component: Build Config → Build Config
Product: Firefox → Core
I do fairly regularly, but I've never tried using gtk 3.

In any case given the problem is a ICE this isn't our problem please file a bug with gcc or maybe redhat
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Elad, those bug should be reported to Red Hat bugzilla because it's a crash in gcc compiler. It has nothing to do with Firefox itself.

Anyway, I don't see any crash when building with gcc-4.8.1-1.fc19.x86_64 in Fedora 19.
(Reporter)

Comment 4

4 years ago
(In reply to Martin Stránský from comment #3)
> Elad, those bug should be reported to Red Hat bugzilla because it's a crash
> in gcc compiler. It has nothing to do with Firefox itself.
I reported this in redhat bugzilla few weeks ago, no reply there yet https://bugzilla.redhat.com/show_bug.cgi?id=1002433
> 
> Anyway, I don't see any crash when building with gcc-4.8.1-1.fc19.x86_64 in
> Fedora 19.
downgrading to gcc-4.8.1-1.fc19.x86_64 did not help
(Reporter)

Updated

4 years ago
You need to log in before you can comment on or make changes to this bug.