[RFE] Link checker

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
Composer
P4
enhancement
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: Akkana Peck)

Tracking

(Blocks: 1 bug)

Trunk
mozilla0.9.7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch attached, awaiting r= and sr=)

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

17 years ago
It would be great to have a link checker which could validate URLs for links,
images, js src and other URLs within the document.

4.x had a Java plug-in which did this.
(Assignee)

Comment 1

17 years ago
Marking moz 1.0 for feasability study.  If it turns out to be hard, it will
probably be bumped back.  But if it's easy, why not just do it?
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Summary: Want: link checker → [RFE] Link checker
(Assignee)

Comment 2

17 years ago
Darin, bbaetz and I worked through the netlib part of this task on Friday and
discovered some snags which might need to be fixed on the netlib end.  Adding
dependencies.
Depends on: 93580, 93581, 93582
(Assignee)

Comment 3

17 years ago
I have code that basically works to list the broken URLs, though Darin and I
agreed that some of this functionality belongs in netlib (filed bug 87677 on
that).  Attaching patch.  I'd like to get this in as work in progress (still in
the debug menu) since a lot of the code (the part that manages the asych calls)
will still be needed even after the new netlib API is added.
Charley, can you review this?  (Again, as work-in-progress, not yet exposed
outside the debug menu.)  Also, we should discuss what the UI should look like,
sometime at your convenience.
Depends on: 97677
(Assignee)

Comment 4

17 years ago
Created attachment 47755 [details] [diff] [review]
Patch: some async link checking code
(Assignee)

Comment 5

17 years ago
Created attachment 48507 [details] [diff] [review]
Better patch: handles buggy NS server 3.6

Comment 6

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer
(Assignee)

Updated

17 years ago
Whiteboard: Partial patch attached, awaiting r= and sr=
(Assignee)

Updated

17 years ago
Attachment #47755 - Attachment is obsolete: true

Comment 7

17 years ago
Comment on attachment 48507 [details] [diff] [review]
Better patch: handles buggy NS server 3.6

r=cmanske
Attachment #48507 - Flags: review+
(Assignee)

Updated

16 years ago
Blocks: 108296
(Assignee)

Comment 8

16 years ago
This broke sometime since it was checked in.  I have a fix that makes it work
again.  Seeking review.  Meanwhile, I filed bug 108296 to get some sort of UI
for this feature so that we can expose it.
(Assignee)

Comment 9

16 years ago
Created attachment 56351 [details] [diff] [review]
small patch: fix regressions
(Assignee)

Updated

16 years ago
Whiteboard: Partial patch attached, awaiting r= and sr= → patch attached, awaiting r= and sr=
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla0.9.6

Comment 10

16 years ago
Comment on attachment 56351 [details] [diff] [review]
small patch: fix regressions

sr=kin@netscape.com
Attachment #56351 - Flags: superreview+

Comment 11

16 years ago
Comment on attachment 56351 [details] [diff] [review]
small patch: fix regressions

r=brade
Attachment #56351 - Flags: review+

Comment 12

16 years ago
Comment on attachment 56351 [details] [diff] [review]
small patch: fix regressions

r=cmanske
(Assignee)

Updated

16 years ago
Attachment #48507 - Attachment is obsolete: true
(Assignee)

Comment 13

16 years ago
Didn't make the milestone deadline -- flu interfered.  Will go in asap.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 14

16 years ago
Oops, this got forgotten, but it's in now, finally.

It sometimes crashes checking e.g. http://www.mozilla.org/nonexistant.html, but
I'll file a backend bug on that.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Depends on: 112985

Updated

16 years ago
No longer depends on: 112985

Comment 15

16 years ago
how am I supposed to test this ?

I saw Check Links in the Debug menu, but that doesn't seem
to do anything...I did enter links in a new blank page and was
hoping that CHeck Links would do something....I entered valid
and invalid URLs.
(Assignee)

Comment 16

16 years ago
Charley?  The dialog code isn't working -- looks like it regressed again!
It's giving:

Trying to match attribute 'href'
Looking at tag 'A'
 Exception ERROR in Link checker. e.result=2147746065, gNumLinksToCheck=5

for each link it tries to check.  Is this working for you?

Obviously, we need to put link checking on our smoketest list, because that's
the only way we're going to keep from getting regressed every few weeks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 17

16 years ago
debug menu items will not get smoketested...

if this is something that is unstable, we should consider taking
it out...
(Assignee)

Comment 18

16 years ago
It's going to move into the regular menus as soon as we have the dialog working.
 It's only in debug because we didn't have UI for it before now.

Comment 19

16 years ago
I think we should resolve this bug as fixed, and follow the issue with bug 108296,
which is about the UI (which is not complete yet.)
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 20

16 years ago
I can verify that's its working by my use of the code
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.