Closed Bug 913927 Opened 7 years ago Closed 7 years ago

Can't zoom in after a maximum zoom out

Categories

(Core :: Panning and Zooming, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 932525

People

(Reporter: jimm, Unassigned)

References

()

Details

(Whiteboard: [block28])

STR:

1) load test case image
2) pinch to zoom all the way out (shrinking image)
3) try to zoom out

result: image doesn't zoom out
(In reply to Jim Mathies [:jimm] from comment #0)
> STR:
> 
> 1) load test case image
> 2) pinch to zoom all the way out (shrinking image)
> 3) try to zoom out
> 
> result: image doesn't zoom out

step 3 should be try to zoom in
Summary: Can't zoom out after a maximum zoom in → Can't zoom in after a maximum zoom out
Blocks: 915724
No longer blocks: metro-apzc
I can reproduce this if in step 3 I try to zoom in by pinching near the center of the screen. If I pinch in the top-left quadrant of the screen I do get a response (although it's kind of jumpy). Turning on layer borders shows that the purple border (which is what our hit tests use) shrinks upon zooming out and so the hit tests starts failing unless you pinch specifically inside that area.

Although I think fixing bug 732971 might make this bug less obvious, this is a legitimate bug and should be addressed separately.
Component: Pan and Zoom → Panning and Zooming
Product: Firefox for Metro → Core
For my own future reference, I think the problem here is that the untransforms in APZCTreeManager to find the right APZC is not working as I expected. If an async transform is in effect on a layer (such as after zooming out on the image above) but there are parts of the layer that extend beyond the originally-visible rect (the purple border) then the hit test should match on those parts as well.
Not able to reproduce this anymore.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
I can still repro this (with some help from turning on layer borders), but bug 932525 might take care of it.
Status: RESOLVED → REOPENED
Depends on: 932525
Resolution: WORKSFORME → ---
Whiteboard: [block28]
I suspect this one is fixed by bug 932525 although I can't test it right now because my local build has a bunch of other patches applied that will interfere with this. Botond, could you verify to see if this is fixed?
Flags: needinfo?(botond)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> I suspect this one is fixed by bug 932525 although I can't test it right now
> because my local build has a bunch of other patches applied that will
> interfere with this. Botond, could you verify to see if this is fixed?

Looks like it's fixed.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: needinfo?(botond)
Resolution: --- → DUPLICATE
Duplicate of bug: 932525
You need to log in before you can comment on or make changes to this bug.