If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Copy menu of contextmenu is disabled in Browser Console

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Console
RESOLVED WONTFIX
4 years ago
a year ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Reproducible: sometimes

Steps To Reproduce:
1. Start Firefox with Clean Profile
2. Open Browser Console
3. Right click on a log
4. Attempt to copy

Actual Results:
Copy menuitem is grayed and disabled.

Expected Results:
Copy menuitem should be enabled.
Thanks for the bug report.

Bug 760876 landed - this patch changed a lot of stuff in the console output. Can you please retest with Firefox nightlies and let us know if you can you still reproduce the bug? Thanks!
Flags: needinfo?(alice0775)
(Reporter)

Comment 2

4 years ago
(In reply to Mihai Sucan [:msucan] from comment #1)
> Thanks for the bug report.
> 
> Bug 760876 landed - this patch changed a lot of stuff in the console output.
> Can you please retest with Firefox nightlies and let us know if you can you
> still reproduce the bug? Thanks!

I can still reproduce the problem.
http://hg.mozilla.org/mozilla-central/rev/9366ee039645
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130915030208

Maybe you misunderstood STR.

3. Right click on a log
   ---- in this case there are no selected item/text
4. Attempt to copy
   ---- The clicked log item(incl. time, description, url and line) should be copied to clipboard.
Flags: needinfo?(alice0775)
Alice, thank you! I tried the STR you suggest and that is the expected behavior now (since bug 760876). We no longer select the whole message when you right click. Like in any other console, now you need to select some text, then you can copy the selected text. This is working for me in the Browser Console and in the Web Console. Please retest and confirm. Thanks!
(Reporter)

Comment 4

4 years ago
(In reply to Mihai Sucan [:msucan] from comment #3)
> Alice, thank you! I tried the STR you suggest and that is the expected
> behavior now (since bug 760876). We no longer select the whole message when
> you right click. Like in any other console, now you need to select some
> text, then you can copy the selected text. This is working for me in the
> Browser Console and in the Web Console. Please retest and confirm. Thanks!

Ok, I understand.
(But, I dislike this behavior)
Can we mark this bug as WFM then?
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 6

a year ago
(In reply to Mihai Sucan [:msucan] from comment #3)
> We no longer select the whole message when
> you right click. Like in any other console, now you need to select some
> text, then you can copy the selected text.

It seems this is no longer the case today.

What happens for me in FF 48:
1. open Browser console
2. rightclick any entry inside the console, Copy item is disabled
3. dismiss the context menu in any way (left click outside the menu, or ESC)
4. now right-click any entry in the console. Copy suddenly is enabled and works

The copy item copies the whole entry (all fields/columns), without needing to select anything.

Alice, can you confirm?
Flags: needinfo?(alice0775)

Comment 7

a year ago
Maybe fixed by bug 1100562 (can be duped?).
(Reporter)

Comment 8

a year ago
I can confirm the inconsistency behavior of comment #6. 
Anyway, This is secondary UI. WONTFIX is enough for me.
Flags: needinfo?(alice0775)
You need to log in before you can comment on or make changes to this bug.