Switch to the Persona observer API. Remove step from registration with Persona.

RESOLVED FIXED in 2013Q3

Status

P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: atopal, Assigned: rrosario)

Tracking

unspecified
2013Q3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=account p=2 s=2013.19)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
When people click the activation link in their Persona email address validation email, they are taken to persona.org. That creates another window or tab, and the disoriented user is taken out of the AAQ process.

Instead clicking the activation link should redirect people back into the AAQ process and ask for their username as the next step.

Since we need this before we can rollout, let's figure out if there is a way to get this into the current sprint. Putting this into the next one for now.
(Reporter)

Updated

5 years ago
Blocks: 897048
(Assignee)

Comment 1

5 years ago
I just went through this process and there is something else.

Yes, clicking the activation link opens a new tab with your persona account information. BUT, you still aren't signed in to SUMO. The popup is still open waiting for you to enter your password. Once you go enter your password, then you get signed in to SUMO. So it is confusing, but I think if the user finds their way back to the popup, they will know to go to the SUMO tab after.
(Assignee)

Comment 2

5 years ago
:callahad, is there anything we can do here to change the workflow for new persona users not using gmail/ldap/etc?
For what it is worth, people with Gmail, Yahoo, or Mozilla accounts will use a different kind of process. Instead of verifying their email address by having them click a link in an email, Persona verifies the user's email address by sending them through a Google or Yahoo OAuth-like login page.

I don't know what percentage of users this helps.
(Reporter)

Comment 4

5 years ago
Ricky, not sure how you get there. Actually, you give your email address on the first screen of the pop-up, then your password on the next screen. Only then do you get the email to verify your email address. Once you click the verification link in the email the pop-up goes away, and the sumo page is asking for your user name.

However, there is another issue with the persona.org page being the link target. When the user has closed the pop-up (not uncommon I guess), they have to find their way back and have to click the "sign-in with email" link again, picking their email address to sign in once more. Only then do they see the "we need your username" field.
(Assignee)

Comment 5

5 years ago
(In reply to Kadir Topal [:atopal] from comment #4)
> Ricky, not sure how you get there. Actually, you give your email address on
> the first screen of the pop-up, then your password on the next screen. Only
> then do you get the email to verify your email address. Once you click the
> verification link in the email the pop-up goes away, and the sumo page is
> asking for your user name.

That's interesting.. For me it was:
1- Enter email address in persona popup
2- Enter a new password twice to set it
3- Open email and click activation link, I end up on Account management page on persona.org
4- Check persona popup, it wants me to enter the password again. I enter it, popup closes, main browser window gets focus (but it doesnt open the sumo tab for me).
Hey folks! Turns out you can pass a `returnTo` URL in your call to .request() to set a specific page for users to get redirected to after verifying their email.  E.g., navigator.id.request({siteName: "SUMO", returnTo: "/auth/post-confirmation"});

If I recall correctly, however, that *should* be defaulting to SUMO itself already. Let me double check that it works...

As for Ricky's situation... did you open the confirmation link in a different browser?
Yeah, I can't reproduce this.

Steps:

1. Go to 123done.org and click sign in.
2. Enter <something>@mailinator.com into the popup
3. Create a password
4. Open a new tab to check your mailinator.com email
5. Click the confirmation link

Which I click the confirmation link, a new window opens, loads 123done, and I'm signed in.

The popup also dismisses itself and I'm similarly signed in on the original tab.

Can someone suggest a different set of steps that land me at the account manager page?
I just took a peek at the staging site. I noticed you're using the `navigator.id.get` API. The problem you're describing is the exact reason we implemented the `navigator.id.watch` API. It will let us redirect back to your website, and the user will then be signed in, without having to click the Sign In button again.

Docs are here[1], and I'm available to help with any questions regarding how to use it.

[1]: https://developer.mozilla.org/en-US/docs/Web/API/navigator.id#ObserverMethods
Another way we can improve this is to include sumo branding and background color.  You can read more about the background color feature and the idea [1].  Since that post, however, we've really simplified language and brought the site branding into confirmation emails.  Attaching two screenshots, one of the site branded sign in dialog, and another for the site branded verification email.

To get all this, use redirectTo, use backgroundColor, and use siteLogo [2].

As sean said, we're all here to help.

[1]: http://identity.mozilla.com/post/55796551587/persona-a-login-that-matches-your-site
[2]: https://developer.mozilla.org/en-US/docs/Web/API/navigator.id.request
(note, improved email branding is not landed yet, it's a feature coming in the next month or so, hopefully that lines up with your work)
Created attachment 802808 [details]
What improved site branding in email will look like when it lands
Created attachment 802809 [details]
What improved site branding in dialog looks like today in production.
(Reporter)

Comment 13

5 years ago
Thanks a lot for getting back to us about the redirect URL, and great to hear about the the branding opportunities. I filed bug 915086 for the pop-up, and bug 915091 for the email. Since we are launching next week already, we'll have to launch without the personalized email, but we'll come back to that as soon as that is possible.
(Assignee)

Comment 14

5 years ago
I estimate the switch to the .watch() to be ~2pts.
Whiteboard: u=user c=account p= s=2013.19 → u=user c=account p=2 s=2013.19
(Assignee)

Updated

5 years ago
Blocks: 916079
(Assignee)

Updated

5 years ago
Blocks: 915086
(Assignee)

Comment 15

5 years ago
This bug is only about switching to the Observer API per comment 8. After looking a little at that, I think this change is more involved than I expected. Making this a 3pter.
Summary: Remove step from registration with Persona → Switch to the Persona observer API. Remove step from registration with Persona.
Whiteboard: u=user c=account p=2 s=2013.19 → u=user c=account p=3 s=2013.19
(Assignee)

Comment 16

5 years ago
giving it a shot!
Assignee: nobody → rrosario
(Assignee)

Comment 17

5 years ago
Pull request:
https://github.com/mozilla/kitsune/pull/1625

Landed in master:
https://github.com/mozilla/kitsune/commit/3aed6a939242ce1d3c09cf528e7b566de98f0ae0


Lowering back to 2pts.
Whiteboard: u=user c=account p=3 s=2013.19 → u=user c=account p=2 s=2013.19
(Assignee)

Comment 18

5 years ago
This is on stage which is all that matters at this point.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

5 years ago
Note that now when a new user signs in for the first time with the fallback (email confirmation) provider, they will probably end up with two tabs to sumo. I guess this is better than a tab on sumo and a tab on the persona account management page.
You need to log in before you can comment on or make changes to this bug.