Last Comment Bug 913964 - Don't show 'Ignore Thread', 'Ignore Subthread', and 'Watch Thread' menu items on non-mail, special tabs like 'Troubleshooting information'
: Don't show 'Ignore Thread', 'Ignore Subthread', and 'Watch Thread' menu items...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Toolbars and Tabs (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: Thunderbird 26.0
Assigned To: Sebastian H. [:aryx][:archaeopteryx]
:
Mentors:
Depends on:
Blocks: 930424
  Show dependency treegraph
 
Reported: 2013-09-08 15:15 PDT by Sebastian H. [:aryx][:archaeopteryx]
Modified: 2014-04-27 13:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
patch, v1 (1.38 KB, patch)
2013-09-08 15:29 PDT, Sebastian H. [:aryx][:archaeopteryx]
standard8: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review
also hide separator, patch, v1 (1.54 KB, patch)
2013-09-14 09:11 PDT, Sebastian H. [:aryx][:archaeopteryx]
standard8: review+
Details | Diff | Review

Description Sebastian H. [:aryx][:archaeopteryx] 2013-09-08 15:15:41 PDT
Thunderbird 24.0b2, Daily 20130904030204

Don't show 'Ignore Thread', 'Ignore Subthread', and 'Watch Thread' menu items on non-mail, special tabs like 'Troubleshooting information'.
Comment 1 Sebastian H. [:aryx][:archaeopteryx] 2013-09-08 15:29:34 PDT
Created attachment 801298 [details] [diff] [review]
patch, v1

[Approval Request Comment]
Regression caused by (bug #): bug 179033
User impact if declined: Context menu in non-mail tabs shows "Ignore Thread", "Ignore Subthread", "Watch Thread" (haven't tested what happens if you click on them)
Testing completed (on c-c, etc.): no
Risk to taking this patch (and alternatives if risky): [If the context menus match]: None.
Comment 2 Mark Banner (:standard8) 2013-09-09 14:16:26 PDT
https://hg.mozilla.org/comm-central/rev/52ce01123f03
Comment 4 Sebastian H. [:aryx][:archaeopteryx] 2013-09-14 09:11:00 PDT
Created attachment 804900 [details] [diff] [review]
also hide separator, patch, v1

I hadn't added the new separator to the list of separators, so it gets shown at the end of the menu. This patch hides it.

I will file a bug to remove this static separator list in later Thunderbird versions.
Comment 5 Sebastian H. [:aryx][:archaeopteryx] 2013-09-14 13:06:13 PDT
(In reply to Archaeopteryx [:aryx] from comment #4)
> I will file a bug to remove this static separator list in later Thunderbird
> versions.
Filed as bug 916482.
Comment 6 Mark Banner (:standard8) 2013-10-20 11:44:23 PDT
Comment on attachment 804900 [details] [diff] [review]
also hide separator, patch, v1

Looks good, but if we want this on branches, please move the patch to a separate bug so we can use the tracking flags appropriately.

Note You need to log in before you can comment on or make changes to this bug.