Closed Bug 913994 Opened 8 years ago Closed 8 years ago

[Buri][SMS] SMS to number included in SMS is not show

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

defect

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: sync-1, Assigned: julienw)

Details

(Whiteboard: [comms-triaged])

Attachments

(1 file)

Mozilla build ID:20130902041201
 
 DEFECT DESCRIPTION: Device is not showing message send to number included in an SMS, the only way to show the message is to go back and enter again in the conversation.
 
  EXPECTED BEHAVIOUR: Device must show message send to number included in SMS
 
  REPRODUCING PROCEDURES:
 1.- Arrange to receive SMS including one number
 2.- Once the message is received, do a long press on number, device will show 2 options "Call" and "Send message"
 3.- Select "Send message" and write new message.
 4.- Write text and send it, you will see than after SEND the message, the "conversation" or send message is not show.
 5.- the only way to show it is going back and then enter again in the conversation.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT: Wrong MMI
 
  REPRODUCING RATE: 100%
 
  For FT PR, Please list reference mobile's behavior:
blocking-b2g: --- → leo?
Can you please make a video ?

I just tried it myself and it worked for me.
Flags: needinfo?(sync-1)
Dear Julien Wajsberg,

I test it with the patch given by bug 907562, if not using this patch, it is ok. But I see the patch is in the master, it is dangerous.
Flags: needinfo?(sync-1)
Ah, ok I see this now. I think I was testing on 1.1, and this is not happening on 1.1 (bug 907562 is not in 1.1). But I see it in master now, so I'm asking koi? instead.
blocking-b2g: leo? → koi?
Note: I'd like we try to write an integration test for this bug, this sounds like a good candidate.
Assignee: nobody → felash
should bug 907562 backout if it causes this bug?
Flags: needinfo?(felash)
Whiteboard: [comms-triaged]
It's there for 1 month, will be difficult to back out.

Will rather fix it, will have a patch probably today.
Flags: needinfo?(felash)
Attached patch patch v1Splinter Review
see also PR at https://github.com/mozilla-b2g/gaia/pull/12515

The problem was simple: we were not resetting inThread when handling the #new
hash.
---
 apps/sms/js/message_manager.js             |    1 +
 apps/sms/test/unit/message_manager_test.js |    3 ++-
 2 files changed, 3 insertions(+), 1 deletion(-)
Attachment #811326 - Flags: review?(gnarf37)
Comment on attachment 811326 [details] [diff] [review]
patch v1

LGTM
Attachment #811326 - Flags: review?(gnarf37) → review+
master: adca6a4ff0332538a5d217d41f1f5e0388453d15
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
blocking-b2g: koi? → koi+
Uplifted adca6a4ff0332538a5d217d41f1f5e0388453d15 to:
v1.2: c26235e265e175aba292eb051b74398463d4cfbc
You need to log in before you can comment on or make changes to this bug.