[email] Bad recipients with clearly invalid e-mail addresses are not detected prior to sending, send does not report specific error codes on failure

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

({feature})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:
There is no warning(eg. the dress is invalid,pls check it.) when sending a new email with invalid address(eg. xxxxx),
【Repro Steps*】:
1、open email app
2. write a new email with a invalid address(eg.  123456)
3. click send button.





Actual results:

【Real Result*】:
Alert sending email failed.

【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】:134356dc21d0627455f8bc536b140a18f39e20e9
【Gecko commit ID*】:2e2b4393b0581ef72a1cb70fc5f002cd82a9302a
【Gonk commit ID*】:ca9192d7ef6037016d4723647d86b72f7a410633


Expected results:

【Expect Result*】:
alert the address is invalid, please check it.
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
OS: All → Gonk (Firefox OS)
Priority: -- → P2
Hardware: All → ARM
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
Dominic, I think this would be classified as a feature request?

NI myself to revisit
blocking-b2g: hd? → ---
Flags: needinfo?(wchang) → needinfo?(dkuo)

Updated

5 years ago
Flags: needinfo?(wchang)
(Reporter)

Comment 2

5 years ago
to Wayne:
Could you tell me whether this request is supported on V1.1HD or not?
Flags: needinfo?(wchang)

Comment 3

5 years ago
Wayne, yes this should be a feature request, I took a quick test and found email didn't check if the address is valid format or not.

Andrew, is this already in the backlog or in the productivity team sprint planning? thanks.
Flags: needinfo?(dkuo) → needinfo?(bugmail)
(In reply to lecky from comment #2)
> to Wayne:
> Could you tell me whether this request is supported on V1.1HD or not?

Comment 3 answers your question.

Not for v1.1/HD.
Flags: needinfo?(wchang)
There's no existing bug for this.  There are 2 things we can do here:

- Detect clearly invalid e-mail addresses before attempting to send.  This will benefit asynchronous mail sending too.

- Add more strings to the UI describing the type of failure encountered.

The SMTP back-end will tell us things like 'bad-recipient'/'bad-sender'/'bad-message'/'server-maybe-offline'/etc, but we only ever generate a single string.  Note that bad-recipient could include completely invalid e-mail addresses, or in the event the SMTP server we are using attempts to resolve locally hosted messages, it may be able to indicate that some of the recipients simply don't exist.  (For example, typing 'bbo@example.com' when you mean 'bob@example.com'.)

The ActiveSync back-end does not generate as many error codes, although we could make it smtarter.


I'm adding this to our koi triage list since this is something we should discuss.  Note that the bad case is not as bad as it could be for SMTP.  Since we only generate the message buffer when it comes time to issue the DATA command and we get 'RCPT TO' failures prior to that, we should bail without having constructed the full message buffer or having sent any of the body including potentially large attachments, etc.
Severity: blocker → enhancement
blocking-b2g: --- → koi?
Flags: needinfo?(bugmail)
Priority: P2 → --
Summary: [B2G][Helix][Email][Baoqing Wu]There is no warning when sending a new email with invalid address(eg. xxxxx), → [email] Bad recipients with clearly invalid e-mail addresses are not detected prior to sending, send does not report specific error codes on failure
blocking-b2g: koi? → 1.3?
Keywords: feature
triage: feature request, moving to consideration for 1.3
(Reporter)

Comment 7

5 years ago
This can'e be fixed on V1.1HD, could you accept it?
Flags: needinfo?(brg)
(In reply to lecky from comment #7)
> This can'e be fixed on V1.1HD, could you accept it?
Agree with comment 4. We are happy to see that it can be consider as a new feature for v1.3.
Flags: needinfo?(brg)

Updated

5 years ago
blocking-b2g: 1.3? → ---
A UX plan for detecting and allowing editing of erroneous addresses has been detailed in bug 949498 which should address this bug.  Marking us as dependent on that bug.
Status: UNCONFIRMED → NEW
Depends on: 949498
Ever confirmed: true
Duplicate of this bug: 1163529

Comment 11

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.