Closed Bug 914026 Opened 6 years ago Closed 6 years ago

Crash resizing a detached-iframe (or closed) window

Categories

(Core :: DOM: Core & HTML, defect, critical)

x86_64
macOS
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox25 --- unaffected
firefox26 + fixed
firefox27 + verified
b2g-v1.2 --- fixed

People

(Reporter: jruderman, Assigned: kanru)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression, testcase)

Crash Data

Attachments

(2 files)

Regression from bug 891763.

+ if (mDocShell->GetIsBrowserOrApp()) {

With this testcase, mDocShell is null, so it crashes.
Attachment #810435 - Flags: review?(khuey)
Comment on attachment 810435 [details] [diff] [review]
Check mDocShell before use

Review of attachment 810435 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #810435 - Flags: review?(khuey) → review+
Keywords: checkin-needed
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/67fadc732e63
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Thanks!
Verified fixed on Nightly 27.0a1 buildid 20131010030202.
Status: RESOLVED → VERIFIED
QA Contact: ananuti
Can we get an uplift nomination here to the beta channel with a risk/reward assessment?
Flags: needinfo?(kchen)
Comment on attachment 810435 [details] [diff] [review]
Check mDocShell before use

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 891763
User impact if declined: browser crashes if the website tries to resize a detached iframe or closed window. 
Testing completed (on m-c, etc.): already in firefox27
Risk to taking this patch (and alternatives if risky): little to none
String or IDL/UUID changes made by this patch: none
Attachment #810435 - Flags: approval-mozilla-beta?
Flags: needinfo?(kchen)
Attachment #810435 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.