Session restore is incorrectly triggered on startup with "closeWindowWithLastTab==false"

RESOLVED DUPLICATE of bug 495123

Status

()

RESOLVED DUPLICATE of bug 495123
5 years ago
5 years ago

People

(Reporter: kuno.meyer, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130905180733

Steps to reproduce:

- create a new profile
- set "browser.tabs.closeWindowWithLastTab" to FALSE.
- close options tab

[Loop]
- open two tabs, each of them browsing to different locations (e.g. http://a, http://b)
- close both tabs by pressing Ctrl-W twice. (you end up with a single blank tab)
- close browser by pressing Ctrl-F4
- start up browser again


Actual results:

In about 80% of the cases, a session restore screen appears on startup ("well, this is embarrassing / Firefox is having trouble recovering your windows and tabs")


Expected results:

Firefox has been closed properly. Session restore should not become active on browser startup.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 495123
You need to log in before you can comment on or make changes to this bug.