Closed Bug 914109 Opened 9 years ago Closed 9 years ago

[B2G][Helix][browser][zhaotao]how to customize phone's ua profile

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 881596

People

(Reporter: lecky.wanglei, Unassigned)

Details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

【Detail Description*】:how to customize phone's ua profile
【Repro Steps*】:
1、Now we only know we can customize ua string according to different website,but still we need ways to provider ua profile to website,to let it know the ability of our cellphone,for example:MaxImageResolution,RenderingScreenSize,etc
2、
3、


Actual results:

【Real Result*】:we have no idea how to customize phone's ua profile,or will it be supported?

【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14
【Gecko commit ID*】:170f9e477571127cd40997fa2abe262ed43f0e4d


Expected results:

【Expect Result*】:we should have some way to customize phone's ua profile
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P2
We have an override for various websites that gets created during the build process : 
/build/ua-override-prefs.js

jsmith, can you help them out more?
Flags: needinfo?(jsmith)
See https://bugzilla.mozilla.org/show_bug.cgi?id=881596#c4.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Flags: needinfo?(jsmith)
Resolution: --- → DUPLICATE
Duplicate of bug: 881596
There have been a few bugs filed on UAProfile; let's not get into the situation we got into with DeviceID in the UA string, where this ends up getting escalated due to lack of communication.

Lawrence/Karl: are you able to follow up some of these filed bugs and assess the risk of that scenario?

Gerv
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.