Closed Bug 914355 Opened 8 years ago Closed 8 years ago

When scrolling down on tumblr.com long pages, firefox crashes.

Categories

(Firefox :: Untriaged, defect)

23 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1015683

People

(Reporter: t8av, Unassigned)

Details

(Keywords: crash, Whiteboard: [bugday-20130916])

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I was viewing a long tumblr.com page which contains a lot of images (such as: http://www.tumblr.com/liked/by/art-asylum).

Scrolling down loads more and more images (can reach thousands).




Actual results:

While scrolling down (page 100 or more), Firefox started to be blank (black color) and after further scrolling, firefox crashed.



Expected results:

Firefox should not crash!

(When scrolling down, Firefox accumulates more and more information, mostly images, which takes a lot of memory. Firefox should release the memory of the first loaded pages in favor of the following pages).
Thanks for taking the time to report this!
Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles .
Flags: needinfo?(t8av)
Whiteboard: [bugday-20130916]
I could not replicate this with the latest Nightly.

Mozilla/5.0 (Windows NT 6.1; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130915030208 CSet: 9366ee039645
(In reply to Swarnava Sengupta (:Swarnava) from comment #1)
> Thanks for taking the time to report this!
> Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode
> disables extensions and themes, hardware acceleration and some JavaScript
> stuff in order to exclude some possible reasons for problems. It does not
> disable plugins which are add-ons.) See
> http://support.mozilla.com/en-US/kb/Safe+Mode 
> 
> And does this also happen with a new and empty profile? See
> http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-
> profile and http://support.mozilla.org/kb/Managing%20profiles .

I apologize for my ignorance - how to use Safe Mode in Firefox?

I suspect this bug is related to the resources that are available for a specific computer at a specific load (i.e. when other programs run), so it cannot be reproduced in some cases.
Flags: needinfo?(t8av)
Well, I tested it, as you requested:

1. Used safe mode.
2. Used a long web page: http://www.tumblr.com/tagged/cartoon
3. Used the middle mouse to scroll down continuously and automatically for about 15 minutes.

It seems that the surfing is much better than I previously experienced.

Possible reasons:
1. Two days ago I cleared all history, cookies, and cache, maybe it has an affect.
2. Maybe one or more of the add-ons causes slowness/hang/crush.

What to check next?
Flags: needinfo?(t8av)
Are you still having problems with FF crashing on tumbler?
Flags: needinfo?(t8av)
Whiteboard: [bugday-20130916] → [bugday-20130916], worksforme?
Now-days I rarely view tumbler, but sometimes there are problems with other image websites, that contain a large number of images.

Moreover, when I try to view images that were photographed by Canon PowerShot A2300, the images often do not show at all (I see black squares). Maybe it is also a hardware issue.
Flags: needinfo?(t8av)
If you find additional long pages that cause Firefox to crash, please provide a link. I don't personally have a tumblr account so I couldn't test the page you provided as an example.

It could be an hardware issue, but it would be nice to get to the bottom of this.  Firefox crashing is never a good thing.
(In reply to t8av from comment #5)
> Well, I tested it, as you requested:
> 
> 1. Used safe mode.
> 2. Used a long web page: http://www.tumblr.com/tagged/cartoon
> 3. Used the middle mouse to scroll down continuously and automatically for
> about 15 minutes.
> 
> It seems that the surfing is much better than I previously experienced.

If it was much better in safe mode, then the problem might be hardware acceleration, no? 

And if it is not, this should be much better in recent versions (29 or 30?) due to changes in handling pages with many images - I forget the bug#
Severity: normal → critical
Keywords: crash
>If it was much better in safe mode, then the problem might be hardware acceleration, no? 
Would be a good guess.

Reporter: 
Can you disable the hardware acceleration in the firefox options: 
options/advanced/general/[]Use hardware acceleration when available 

A restart of Firefox could be necessary and then test again in the normal mode (not Firefox safemode)
(In reply to Matthias Versen [:Matti] from comment #10)
> >If it was much better in safe mode, then the problem might be hardware acceleration, no? 
> Would be a good guess.
> 
> Reporter: 
> Can you disable the hardware acceleration in the firefox options: 
> options/advanced/general/[]Use hardware acceleration when available 
> 
> A restart of Firefox could be necessary and then test again in the normal
> mode (not Firefox safemode)

Looks much better now.

Before disabling the hardware acceleration, when scrolling down in facebook albums, often the Firefox window became black. Creating a new profile did not solve the problem.

I guess that I must disable the hardware acceleration every time that I create a new profile.
Are you still able to reproduce this in the latest Firefox version?
This bug still occurs!!! 

Now I know it is called 'infinite image scrolling', - the browser becomes slow and then crashes when scrolling down with many images.

It happens also in facebook.

As far as I know, the only browser that does not crash, in this situation, is Internet Explorer, but it becomes very slow after many images are loaded.
Could you share your crash report URLs from about:crashes?
AdapterDeviceID: 0x0622
AdapterVendorID: 0x10de
Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:30.0
AvailablePageFile: 1564921856
AvailablePhysicalMemory: 431865856
AvailableVirtualMemory: 134733824
BIOS_Manufacturer: American Megatrends Inc.
BlockedDllList: 
BreakpadReserveAddress: 33619968
BreakpadReserveSize: 37748736
BuildID: 20140605174243
CrashTime: 1406025860
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1402547313
Notes: AdapterVendorID: 0x10de, AdapterDeviceID: 0x0622, AdapterSubsysID: 00000000, AdapterDriverVersion: 9.18.13.1106
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 286
StartupTime: 1406025583
SystemMemoryUsePercentage: 79
Theme: classic/1.0
Throttleable: 1
TotalPageFile: 4293246976
TotalPhysicalMemory: 2146623488
TotalVirtualMemory: 2147352576
Vendor: Mozilla
Version: 30.0
Winsock_LSP: MSAFD Tcpip [TCP/IP] : 2 : 1 :  
 MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [RAW/IP] : 2 : 3 :  
 MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
 MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
 RSVP TCPv6 Service Provider : 2 : 1 :  
 RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
 RSVP UDPv6 Service Provider : 2 : 2 :  
 RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{E84A773B-C53F-48CC-B48A-64B329B45D75}] SEQPACKET 1 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{E84A773B-C53F-48CC-B48A-64B329B45D75}] DATAGRAM 1 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{0A0B2C52-21BA-49C0-8A1D-11E53C172189}] SEQPACKET 3 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{0A0B2C52-21BA-49C0-8A1D-11E53C172189}] DATAGRAM 3 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{09BB0EEB-7B70-4A33-87AB-06D9A9698999}] SEQPACKET 0 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip_{09BB0EEB-7B70-4A33-87AB-06D9A9698999}] DATAGRAM 0 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{933004F2-FB6C-40F6-A331-CA9570C5027C}] SEQPACKET 6 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{933004F2-FB6C-40F6-A331-CA9570C5027C}] DATAGRAM 6 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{62279F66-FED8-47A1-9B6E-3B68A6E6F3BA}] SEQPACKET 8 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{62279F66-FED8-47A1-9B6E-3B68A6E6F3BA}] DATAGRAM 8 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{E84A773B-C53F-48CC-B48A-64B329B45D75}] SEQPACKET 7 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{E84A773B-C53F-48CC-B48A-64B329B45D75}] DATAGRAM 7 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{8C929F04-318B-49D3-BFDE-E7B8851FDB64}] SEQPACKET 5 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{8C929F04-318B-49D3-BFDE-E7B8851FDB64}] DATAGRAM 5 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{0A0B2C52-21BA-49C0-8A1D-11E53C172189}] SEQPACKET 4 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{0A0B2C52-21BA-49C0-8A1D-11E53C172189}] DATAGRAM 4 : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{09BB0EEB-7B70-4A33-87AB-06D9A9698999}] SEQPACKET 2 : 2 : 5 :  
 MSAFD NetBIOS [\Device\NetBT_Tcpip6_{09BB0EEB-7B70-4A33-87AB-06D9A9698999}] DATAGRAM 2 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.
We do not need the "technical details" of the crash. We just need the crash ID that you get from the browser internal page about:crashes, just read https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report#How_to_get_a_crash_ID_with_the_Mozilla_Crash_Reporter
I know that, but after the last crash, I did not see its date at the crash list in about:crashes
ok, I got it now:

bp-877788a1-ab49-4b7e-b798-7e6ec2140722

https://crash-stats.mozilla.com/report/index/877788a1-ab49-4b7e-b798-7e6ec2140722

Before the crash, I created a new profile and set the "use Hardware accelerators" to off.
(In reply to t8av from comment #18)
> ok, I got it now:
> 
> bp-877788a1-ab49-4b7e-b798-7e6ec2140722
> 
> https://crash-stats.mozilla.com/report/index/877788a1-ab49-4b7e-b798-
> 7e6ec2140722
> 
> Before the crash, I created a new profile and set the "use Hardware
> accelerators" to off.

We've had this signature in various forms since 2012. Currently this signature is #2 in Firefox 30 accounting for 7% of our crashes and has been around since 2012. I think bug 805406 is the originating issue.

You can see the various incarnations of this crash by loading your crash report and scrolling down to the Related Bugs section. I think what you're seeing here is just another case which shows this signature. 

The most recent one we fixed was bug 1027103 (fixed in Firefox 32). It's probably worth giving Firefox 32 a try to see if it resolves your issue. You should be able to get it from aurora.mozilla.org. Otherwise we should probably just dupe this to bug 805406.
I forgot to mention that before crash, usually two things happen:

1. Scrolling becomes very slow.
2. I see AVG (anti virus) warning of high memory usage by firefox.
(In reply to t8av from comment #20)
> I forgot to mention that before crash, usually two things happen:
> 
> 1. Scrolling becomes very slow.
> 2. I see AVG (anti virus) warning of high memory usage by firefox.

Can you please try disabling AVG and use the latest Nightly build from nightly.mozilla.org? 

As I said in comment 21, this is like just another trigger for bug 805406. We landed a fix in Firefox 32 that fixed *some* of the triggers of this crash. It would be useful if you can check whether the fix that landed in Firefox 32 has resolved your issue as well.
I will try to install the nightly.

by the way: what is the minimal RAM memory to use Firefox smoothly? I have only 1GB.
Sorry, my mistake - I have 2GB RAM. Is it enough to use Firefox without crashes when using infinite image scrolling in facebook? I guess the browser should keep in memory all the images that were loaded so far.
In both crashes you are pretty much out of virtual memory - a few hundred MB. So if your win7 machine is running 64bit, you might consider running the nightly *64bit* build.

bp-e35c5deb-8a30-490a-96d2-bc3182140723
 mozilla::layers::BasicCompositor::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::Matrix const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::... 

bp-877788a1-ab49-4b7e-b798-7e6ec2140722
 gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*)
Crash Signature: [@ mozilla::layers::BasicCompositor::BeginFrame(nsIntRegion const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, mozilla::gfx::Matrix const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx:…
Crash Signature: , mozilla::gfx::RectTyped<mozilla::gfx::... ] → , mozilla::gfx::RectTyped<mozilla::gfx::... ] [@ gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*)]
Whiteboard: [bugday-20130916], worksforme? → [bugday-20130916]
My win7 is 32 bits.
On a 32-bit system with 1GB of RAM you are more prone to Out-of-memory situations in Firefox. These types of situations usually appear like an aggressive slowing down of the browser followed by a crash which seems to be what you described earlier. 

Our official recommendations for Windows is 512MB of RAM but I routinely see it use more than that (though rarely has it gone over 1GB of use). The more tabs you have open in Firefox, the more add-ons you have, the more plug-in content that's loaded (esp. Flash) all contributes to Firefox's memory usage.

That said, a system with 1GB of RAM with other applications running would not take much for an out-of-memory to occur. I've seen system easily use 4GB of RAM with multiple applications running; 1GB really is not a lot nowadays. It'd probably be wise to add more RAM to your system if you are capable and can afford it. Doing so will benefit your entire system, not just Firefox.
As I wrote in comment 23 above, I have 2GB, not 1GB.

Before I start using Firefox with infinite image scroll (mostly facebook) I close all other applications, but still Firefox crashes.

At the shop where I bought the computer they told me that I should install win7/64 bits. Maybe it will improve the system.

My suggestion to solve the infinite image scroll problem:
Firefox should allow the user to choose a mode in which Firefox releases memory of images that were already loaded.
For example: If on a specific infinite image scroll page there are 40,000 images, after loading of 2000 images, Firefox will release (delete) the memory consumed by the first 1000 images.
I'm not a technical expert in memory management but your suggestion might be good to post to the dev-platform@lists.mozilla.org mailing list. At least there some devs in the know might be able to consider your suggestion.

Unfortunately there's nothing I can really suggest to help you work around what you're experiencing here. The crashes you're seeing are known issues that we've been investigating and continue to investigate. 

For now, bug 1015683 seems like the best bug to dupe this to. My suggestion would be to follow that bug and see if there's anything you can contribute to that investigation. 

I'm sorry, I know this doesn't solve the problem for you. However, the more people we have engaged in the investigation, the more likely we are to find a solution.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015683
I will be happy if you can contact the developers mailing list of my behalf.

When loading too many images into the browser, a crash is inevitable.

I suggest:

1. Save "older images" to local disk instead of keeping them in RAM. For example, if in a page there are 40,000 images, when loading the 5000th image, save all first 5000 images to local disk, or delete them from memory (depends on user preference).

2. Allow the user to save all currently opened tabs to local disk to free RAM memory.

I have raised these suggestions in the past, and I got a negative response, but since crashes continue to happen in all Firefox versions, then I think my suggestions should be seriously considered. 

Also: these suggestions are very easy to implement!
Chrome seems to have the same problems... at least it's only the page crashing not the browser.
However Google doesn't like "endless scrolling pages" as it seems to be very different for them (or search engines in general) to find search-results.

https://developers.google.com/web/updates/2016/07/infinite-scroller
You need to log in before you can comment on or make changes to this bug.