Closed Bug 914390 Opened 7 years ago Closed 7 years ago

[Buri][Music] Sometimes the music player freezes and won't play any tracks

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 914870
blocking-b2g koi+

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file musicfreeze.txt
Buri, while running:

Gaia   aa4180e9286d385fa6b62d236f30fb24cd8b93e9
SourceStamp 218d4334d29e
BuildID 20130909114657
Version 26.0a1

STR:
1. Launch the music app
2. Try to play a track from the home page

Expected: I could play the track when I select it
Actual: Nothing happens.

I can reproduce this on two different Buri devices.  Logcat attached.

Sometimes the music will play if I close the app and restart it.
It's another GENLOCK error bug with graphics.

09-09 15:36:50.541: E/libgenlock(1291): perform_lock_unlock_operation: GENLOCK_IOC_DREADLOCK failed (lockType0x1, err=Connection timed out fd=37)
09-09 15:36:50.541: E/msm7627a.gralloc(1291): gralloc_lock: genlock_lock_buffer (lockType=0x2) failed
blocking-b2g: --- → koi?
Component: Gaia::Music → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk
QA Contact: laliaga
I am unable to repro while on the same build/gecko/Gaia versions on Buri device. My SD card had several different albums nested both in folders and on the root of the SD. Attempted with both a full and mostly empty SD. I also had different bitrates and audio formats with no results. Leaving in case someone else can get a repro.

Environmental Variables
Build ID: 20130909114657
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1
QA Contact: laliaga
reproduces for me, 

Regression range:
Build ID: 20130906040204 - Does NOT Reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
Platform Version: 26.0a1

Build ID: 20130909114657 - Reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
Platform Version: 26.0a1
The push log shows changes that Nicolas worked on in relation to this.

Nicolas - Any ideas?
Flags: needinfo?(nical.bugzilla)
Is there any canvas element or video element when the hang occurs? Lately my work has only been affecting these two code paths.
A lot of genlock failures investigation is going on in Bug 912134 which will most likely result in us changing how we unlock gralloc buffers, so it will most likely affect this bug too.
Flags: needinfo?(nical.bugzilla)
(In reply to nkot from comment #3)
> reproduces for me, 
> Regression range:
> Build ID: 20130906040204 - Does NOT Reproduce
> Gecko: http://hg.mozilla.org/mozilla-central/rev/ab5f29823236
> Gaia: 94e5f269874b02ac0ea796b64ab995fce9efa4b3
> Platform Version: 26.0a1
> 
> Build ID: 20130909114657 - Reproduces
> Gecko: http://hg.mozilla.org/mozilla-central/rev/218d4334d29e
> Gaia: aa4180e9286d385fa6b62d236f30fb24cd8b93e9
> Platform Version: 26.0a1

I afraid I misunderstood this bug, while the symptoms I'm seeing are very similar, there is no such error in my log
09-09 15:36:50.541: E/libgenlock(1291): perform_lock_unlock_operation: GENLOCK_IOC_DREADLOCK failed (lockType0x1, err=Connection timed out fd=37)
09-09 15:36:50.541: E/msm7627a.gralloc(1291): gralloc_lock: genlock_lock_buffer (lockType=0x2) failed

What I've reproduced is being tracked in bug 914870,
provided regression range is not accurate, sorry about that.
Blocks: GFXB2G1.2
Unable to reproduce in 'emulator' config.

I have put one mp3 file in /sdcard/Music. I start the Music app, touch the album for this mp3 file, it plays fine. Using mozilla-central 218d4334d29e, gaia 753bed59566.
Unable to reproduce on unagi.
I can see this all the time on my device. I guess maybe this is a dupe of Bug 914870, but the delay in some cases is so long, and during that period the UI controls are frozen and I have to force kill the app. But the song eventually does start playing so duping to Bug 914870.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914870
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.