Can't get keyboard focus without Window Manager

VERIFIED DUPLICATE of bug 76854

Status

()

--
major
VERIFIED DUPLICATE of bug 76854
18 years ago
18 years ago

People

(Reporter: dolivari, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I try to use mozilla in fullscreen with an appropiate XUL and without Window
Manager. It has worked fine with earlier version of Mozilla (M18).
But now I can't get any keyboard event sent to my JS.
(Reporter)

Comment 1

18 years ago
Created attachment 42837 [details]
A focus test for fullscreen use
(Reporter)

Comment 2

18 years ago
How to use the usecase :
- Be in console mode.
- Start X alone : "$> X &" . If you have an X server already running you can
type "$> X :1 &"
- Come Back to command line CTRL+ALT+F1
- Set Display : "$> export DISPLAY=:0" or "$> export DISPLAY=:1" 
- Launch mozilla : "$> mozilla -chrome file://<PATH TO ATTACHED FILE>/focus.xul"
- Try to press the button
- Try to press DEL key
- Try to enter charachters in text field
- Exit all this
- Come Back to your desktop environment (Enlightenment, XFCE, Gnome, KDE...)
- Launch mozilla : "$> mozilla -chrome file://<PATH TO ATTACHED FILE>/focus.xul"
- Try to press DEL key
- Try to press the button
- Try to enter charachters in text field
Duplicate of "Mozilla ignores keyboard input if a window manager is not used"

*** This bug has been marked as a duplicate of 76854 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.