[B2G][Helix][usage][yangshiqi]If we change date to the future month in settins ,the "usage" period will stay in future month and don't go back if we change the date back.

RESOLVED DUPLICATE of bug 911080

Status

Firefox OS
Gaia::Cost Control
P2
normal
RESOLVED DUPLICATE of bug 911080
5 years ago
5 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

982.80 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 802006 [details]
20130910112352786.zip

User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:[B2G][Helix][usage][yangshiqi]If we change date to the future month in settins ,the "usage" period will stay in future month and don't go back if we change the date back. 
                         1.change the date to next month in settings.
			 2.enter into usage to synchronize time,the "usage" period will become future month.
			 3.change the date back
			 4.enter into useage 
【Expect Result*】:the "usage" period will go back.
【Real Result*】:the "usage" period will stay in future month and don't go back if we change the date back. 
【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:20130910112352786.zip
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P2

Updated

5 years ago
Component: Gaia → Gaia::Cost Control
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
qawanted to check if this is reproduced.

Won't consider as a blocker given the description is tampering with the time settings. Please renom if any one feels otherwise.

Salva, something you can look at?
Severity: blocker → normal
blocking-b2g: hd? → ---
Flags: needinfo?(wchang) → needinfo?(salva)
This is a knows problem related to BE. Also, this bug is a duplicate of bug 911080. See the explanations there.

Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(salva)
Resolution: --- → DUPLICATE
Duplicate of bug: 911080
(Reporter)

Comment 3

5 years ago
Accoding to the duplicate of bug 911080,it seems this will not solve in v1.1,please confirm will that be acceptable?
Flags: needinfo?(brg)
We know this behaviour and it is accepted in v1.1.
Flags: needinfo?(brg)
You need to log in before you can comment on or make changes to this bug.