Closed Bug 914480 Opened 6 years ago Closed 6 years ago

[Tracker] Plan for tegra and related infrastructure move out of 650 castro

Categories

(Release Engineering :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: hwine)

References

Details

(Keywords: meta)

Attachments

(1 file)

So hal asked me to file this bug to track working knowledge on the plan for tegras/foopies/pdus/etc that currently live in 650 castro and will live in the new mtv office.

We'll eventually move all tegras and foopies to new office.

====
Currently Known After move bringup work:

Tegras:
* Be sure they have power through a PDU
* Verify no airflow interference
* Inventory/DNS should be setup/working at new home before these connect to network.

PDUs:
* Each tegra should either have its exact same PDU as it had in 650 castro, or be updated in both pdu's web interface and inventory.
* Tell us each PDU's fqdn so we can update devices.json appropriately.

Foopies:
* Either:
  ** reimage from scratch (pxe boot) as a puppetAgain slave, with new fqdn.
  ** Regenerate new puppetAgain cert with new fqdn and make sure it can successfully talk to puppet
* Ensure that each foopy has a current (in same VLAN) list of devices it will talk back and forth to
* Update tools repo on foopy to tip (with current devices.json info)

=====

We'll likely learn more as plans become more final.
Depends on: 940578
Depends on: 940955
Depends on: 940956
Depends on: 940957
Depends on: 940960
Depends on: 940961
Depends on: 940962
No longer depends on: 940960
No longer depends on: 940961
Depends on: 940964
Depends on: 940968
Assignee: nobody → hwine
Keywords: meta
Callek: you were going to get back to us last week with a firm answer on which tegras were going to be decommissioned.  We need this info now to start doing all of the pre-work for setting up things in scl3.  Is there a bug for that answer that can be linked here, and do you have an eta on when that information will be available?
Flags: needinfo?(bugspam.Callek)
Duplicate of this bug: 946534
Summary: [Meta] Plan for tegra and related infrastructure move out of 650 castro → [Tracker] Plan for tegra and related infrastructure move out of 650 castro
Depends on: 946534
Depends on: 947000
Depends on: 947003
Depends on: 949739
Depends on: 949751
Depends on: 949782
(In reply to Amy Rich [:arich] [:arr] from comment #1)
> Callek: you were going to get back to us last week with a firm answer on
> which tegras were going to be decommissioned.  We need this info now to
> start doing all of the pre-work for setting up things in scl3.  Is there a
> bug for that answer that can be linked here, and do you have an eta on when
> that information will be available?

That was provided and utilized with Bug 918168
Flags: needinfo?(bugspam.Callek)
Depends on: 951209
Depends on: 947184
Adds node defs for fooppies in tegra.releng.scl3.m.c
Attachment #8356140 - Flags: review?(bugspam.Callek)
Attachment #8356140 - Flags: review?(bugspam.Callek) → review?(arich)
Attachment #8356140 - Flags: review?(arich) → review+
Attachment #8356140 - Flags: checked-in+
Depends on: 957278
Depends on: 957355
Depends on: 958140
Move complete.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 958995
You need to log in before you can comment on or make changes to this bug.