Closed Bug 914493 Opened 8 years ago Closed 8 years ago

[Email] iframe is not resized for the embedded images that were already downloaded while building body

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

RESOLVED FIXED
1.2 FC (16sep)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g18-v1.0.1 --- wontfix
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: psingapati)

Details

(Whiteboard: [TD-89251])

Attachments

(3 files)

STR:
1. Create an IMAP account.
2. Receive an email with large bmp image as inline image
3. Message box -> Open the Email -> click to down load the line image
4. Downloaded image shows with scroll bars.
5. Go back
6. Again open the same email

Result: 
Image is not displayed completely 

Expected: 
Image should be displayed with proper scrolling.

Note:
1.Issue reproduced with gaia v1-train.
Attached image Test Image (deleted) —
Test image with which issue reproduces.
Add the attached image as inline and send.
Open the email from FxOS device.
Attached patch Bug_914493.patchSplinter Review
Andrew,

The attached patch has fix for resizing the iframe for embedded images, when we are building body.
Please review and provide feedback.

Thanks.
Flags: needinfo?(bugmail)
Assignee: nobody → psingapati
Comment on attachment 802158 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12059

r=asuth.  I'll land this once it's clear there are no Travis surprises.

Currently skipping unit tests since the tests are about two orders of magnitude more complex than the fix and the fix is a logical consistency issue.  (Use a callback in the other places we use a callback).  For the 1.3 cycle I believe we are planning to fix the message display mechanism which is when I expect us to address the test deficit.

psingapati, if you can mark the bug leo+, I can land this on v1-train for you too.
Attachment #802158 - Flags: review+
blocking-b2g: --- → leo+
Thanks for r+.

made leo+, please land it on v1-train.

Thanks
v1.1.0hd: 946623575b3fbf6138fff5f77ddead3cadffacce
v1.1.0hd: f73489abba922237dcf7ff0c52df2a972bc59b78
Whiteboard: [TD-89251]
You need to log in before you can comment on or make changes to this bug.