[B2G][Helix][AccuWeather][yangshiqi]It is better to add a confirm button if we choose items in main menu.

RESOLVED WONTFIX

Status

P4
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Assigned: devomanager)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 802099 [details]
20130910150632293.txt

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

【Detail Description*】:[B2G][Helix][AccuWeather][yangshiqi]It is better to add a confirm button if we choose items in main menu.
                         1.enter into AccuWeather
			 2.press menu right top of the screen,choose items "
【Expect Result*】: we choose items and press "ok" button than going to relevant page .
【Real Result*】:it don't need to press "ok" button.
【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:20130910150632293.txt
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P2

Updated

5 years ago
Blocks: 868100
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Updated

5 years ago
Severity: blocker → enhancement
blocking-b2g: hd? → ---
Priority: P2 → --

Updated

5 years ago
Assignee: nobody → adora
Donovan, please add some text I can send to Accuweather about best practice here (related to Bug 912223).
Flags: needinfo?(dpreston)
Here is the best practice that would solve this issue:

When using <select><option> menus, both iOS and Firefox OS fire the onchange callback as soon as the user has chosen a new item from the menu. However, both iOS and Firefox OS also have a "Done" or "Ok" button, and it would be better to wait until this has been pressed rather than performing the change logic immediately in onchange. To do this, code should use the onblur event rather than the onchange event. This event handler will fire when the user has pressed the "Done" or "Ok" button rather than as soon as the user has chosen a new item.
Flags: needinfo?(dpreston)

Comment 3

5 years ago
Lisa, please ensure the developer has been notified of Donovan's comment #2.
Priority: -- → P2

Updated

5 years ago
Assignee: adora → hkirschner
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: P2 → P4

Comment 4

5 years ago
Response from Devomanager@accuweather.com: I don't understand what this "bug" is. Screenshots and better explanation of the actual issue needed.

Attaching Screenshot.

Explanation of issue:
-User presses Menu button
-User selects an option, such as "3 Day Forecast"
-User expects the menu to stay open until they press the "OK" button, but instead, as soon as they press the option, the app redirects to that page. Therefore the "OK" button serves no purpose.

See Comment #2 from Donovan Preston for implications and implementation of a fix.

Comment 5

5 years ago
Created attachment 832645 [details]
2013-11-14-16-52-38.png

Image of the menu options. The checkmark represents the user's current selection. When a new item is pressed, the app does not wait for the user to press the "OK" button before redirecting to the selected item's page.

Comment 6

5 years ago
In an effort to leverage native device controls across all platforms, we decided to use the onchange event in the Menu of our mobile web site. We realize not all browsers handle this the same way and rather than adding exceptions for those devices whose native select menus include a Done or OK button, we chose the path of least resistance. iOS was mentioned above as also including a Done button. This is true for the iPhone, but not the iPad. It's also worth noting that the onchange event in iOS (at least v7) will not fire until the user taps the Done button. And I can't comment on what users expect or don't expect. It's difficult to broad-brush an entire user base.
The onchange event fired on iOS before tapping the done button when I tested; that was iOS 6 though I think.

Personally I think that the onchange event should only fire when the OK button is pressed on Firefox OS. It would reduce a lot of confusion.

Comment 8

5 years ago
Michelle, can you provide a date for when this bug will be addressed?
Assignee: hkirschner → devomanager
Flags: needinfo?(devomanager)

Comment 9

5 years ago
Michelle, this bug has been open for over 4 months.  Can you provide a fix by February 17th, please?  Thank you.

Comment 10

5 years ago
Reproduced on Peak v1.3.  Are there any updates regarding this bug?

Comment 11

5 years ago
Message from Eric Guyer - Our App icon links into our HTML5 website where Mozilla users can view the weather.  The menu on our mobile web site does not have a confirm button before going to the users selected content.  This is done by design and is not a bug.  

Changing status to Resolved - Won't Fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(devomanager)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.