Closed Bug 914611 Opened 7 years ago Closed 7 years ago

Inconsistent references to plugin placeholder elements

Categories

(SeaMonkey :: General, defect)

defect
Not set
normal

Tracking

(seamonkey2.23 fixed)

RESOLVED FIXED
seamonkey2.24
Tracking Status
seamonkey2.23 --- fixed

People

(Reporter: neil, Assigned: neil)

References

Details

Attachments

(1 file)

Now that bug 910899 added anonids to the plugin placeholder elements that need it, the front-end code should switch to use them consistently.
Attached patch Proposed patchSplinter Review
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #802287 - Flags: review?(bugzilla)
Blocks: 920677
Neil: Looks like our CTP overlay is broken on trunk, so I'm having a hard time testing everything related to plugin placeholder elements.
Though..maybe this is only a CSS style mistake? Are your comments in Bug 790483 related to that? The plugin placeholder code displays fine in DOMI, it's just the styling being wrong?
Yes, try the patch in bug 920927.
Comment on attachment 802287 [details] [diff] [review]
Proposed patch

That patch in the other bug did not fix it, but r+ for now since this patch seems to block other work/patches (and the patch looks good via code inspection). Need to re-investigate/file a new bug for the CTP problem.
Attachment #802287 - Flags: review?(bugzilla) → review+
Ah of course, you need my as yet nonexistent patch to bug 920677 too.
http://hg.mozilla.org/comm-central/rev/ed457090123f
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 802287 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 790483 via 920677
User impact if declined: No placeholder UI for CTP plugins
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #802287 - Flags: approval-comm-aurora?
Target Milestone: --- → seamonkey2.24
Boy, I made a mess of that checkin...
Attachment #802287 - Flags: approval-comm-aurora? → approval-comm-aurora+
Unsetting flag to make bug appear in the fixed bugs for SeaMonkey 2.23 list only (target milestone is enough for trunk).
You need to log in before you can comment on or make changes to this bug.