Closed Bug 914615 Opened 9 years ago Closed 9 years ago

Intermittent social/test/browser/browser_frameworker.js | Test timed out (when infra is down)

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set
normal

Tracking

(firefox25 fixed, firefox26 fixed, firefox27 fixed, firefox-esr24 fixed)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox25 --- fixed
firefox26 --- fixed
firefox27 --- fixed
firefox-esr24 --- fixed

People

(Reporter: emorley, Assigned: markh)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Seems like this test fails when infra goes down, eg:

Rev3 Fedora 12 mozilla-central debug test mochitest-browser-chrome on 2013-09-10 02:45:40 PDT for push 25bfaa953892

slave: talos-r3-fed-061

https://tbpl.mozilla.org/php/getParsedLog.php?id=27633840&full=1&branch=mozilla-central#error1

{
04:08:47     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | sub-test testTimeouts complete
04:08:47     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | sub-test testWebSocket starting
04:08:47     INFO -  ++DOCSHELL 0x15db9aa80 == 110 [id = 6360]
04:08:47     INFO -  ++DOMWINDOW == 470 (0x15255a158) [serial = 16252] [outer = 0x0]
04:08:47     INFO -  ++DOMWINDOW == 471 (0x16c43bbb8) [serial = 16253] [outer = 0x15255a158]
04:08:47     INFO -  ++DOCSHELL 0x16e484b80 == 111 [id = 6361]
04:08:47     INFO -  ++DOMWINDOW == 472 (0x160d45ab8) [serial = 16254] [outer = 0x0]
04:08:47     INFO -  ++DOMWINDOW == 473 (0x16c4a4e28) [serial = 16255] [outer = 0x160d45ab8]
04:08:47     INFO -  ++DOMWINDOW == 474 (0x169ba6c58) [serial = 16256] [outer = 0x160d45ab8]
04:08:47     INFO -  ++DOMWINDOW == 475 (0x1688f8208) [serial = 16257] [outer = 0x160d45ab8]
04:08:48     INFO -  TEST-PASS | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | check that websockets worked
04:08:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | sub-test testWebSocket complete
04:08:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | sub-test testSameOriginImport starting
04:08:48     INFO -  ++DOCSHELL 0x1599aae80 == 112 [id = 6362]
04:08:48     INFO -  ++DOMWINDOW == 476 (0x168da99f8) [serial = 16258] [outer = 0x0]
04:08:48     INFO -  TEST-INFO | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | Console message: [JavaScript Error: "Firefox can't establish a connection to the server at ws://mochi.test:8888/socketserver." {file: "http://example.com/browser/toolkit/components/social/test/browser/echo.sjs?var%20run=(function%20()%20%7B%0A%20%20%20%20%20%20onconnect%20=%20function(e)%20%7B%0A%20%20%20%20%20%20%20%20let%20port%20=%20e.ports%5B0%5D;%0A%0A%20%20%20%20%20%20%20%20try%20%7B%0A%20%20%20%20%20%20%20%20%20%20var%20exampleSocket%20=%20new%20WebSocket(%22ws://mochi.test:8888/socketserver%22);%0A%20%20%20%20%20%20%20%20%7D%20catch%20(e)%20%7B%0A%20%20%20%20%20%20%20%20%20%20port.postMessage(%7Btopic:%20%22done%22,%20result:%20%22FAILED%20calling%20WebSocket%20constructor:%20%22%20+%20e%7D);%0A%20%20%20%20%20%20%20%20%20%20return;%0A%20%20%20%20%20%20%20%20%7D%0A%0A%20%20%20%20%20%20%20%20port.postMessage(%7Btopic:%20%22done%22,%20result:%20%22ok%22%7D);%0A%20%20%20%20%20%20%7D%0A%20%20%20%20%7D);run();" line: 6}]
04:08:48     INFO -  [Parent 1234] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file ../../../../content/events/src/nsDOMEventTargetHelper.h, line 104
04:08:48     INFO -  [Parent 1234] WARNING: NS_ENSURE_TRUE(!mHasOrHasHadOwnerWindow || mOwnerWindow) failed: file ../../../../content/events/src/nsDOMEventTargetHelper.h, line 104
04:08:48     INFO -  ++DOMWINDOW == 477 (0x165c3cdd8) [serial = 16259] [outer = 0x168da99f8]
...
...
04:09:07  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/components/social/test/browser/browser_frameworker.js | Test timed out
}
The test timed out in:
{
396   testSameOriginImport: function(cbnext) {
397     let run = function() {
398       onconnect = function(e) {
399         let port = e.ports[0];
400         port.onmessage = function(e) {
401           if (e.data.topic == "ping") {
402             try {
403               importScripts("http://foo.bar/error");
404             } catch(ex) {
405               port.postMessage({topic: "pong", data: ex});
406               return;
407             }
408             port.postMessage({topic: "pong", data: null});
409           }
410         }
411       }
412     }
}

importScripts("http://foo.bar/error");

ha..
Thanks for the analysis Ed!  This patch uses mochi.test:8888 instead of foo.bar.
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #802705 - Flags: review?(mixedpuppy)
That's great, thank you :-)
Comment on attachment 802705 [details] [diff] [review]
0001-Bug-914615-use-http-mochi.test-8888-instead-of-http-.patch

Were you able to reproduce the timeout locally with no net connection?
Attachment #802705 - Flags: review?(mixedpuppy) → review+
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #4)
> Comment on attachment 802705 [details] [diff] [review]
> 0001-Bug-914615-use-http-mochi.test-8888-instead-of-http-.patch
> 
> Were you able to reproduce the timeout locally with no net connection?

I didn't try TBH - it seemed fairly clear to me that the test should have been using a "test" URL rather than a "real" one.  Do you think I should spend the time to try and repro?
I pushed https://hg.mozilla.org/integration/fx-team/rev/ea9c441a7ed4 as the patch is simple and using http://foo.bar is clearly not a great idea for tests.

However, this bug has since morphed to what looks like some other error, so adding [leave open] while we investigate the new issues.
Whiteboard: [leave open]
(In reply to Mark Hammond (:markh) from comment #11)
> However, this bug has since morphed to what looks like some other error, so
> adding [leave open] while we investigate the new issues.

Think we should file another bug for that; happy to close this one out once it merges :-)
Whiteboard: [leave open]
https://hg.mozilla.org/mozilla-central/rev/ea9c441a7ed4
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
(In reply to Mark Hammond (:markh) from comment #5)
> I didn't try TBH - it seemed fairly clear to me that the test should have
> been using a "test" URL rather than a "real" one.  Do you think I should
> spend the time to try and repro?

Probably not, just wasn't sure about the confidence that this would fix it.
Blocks: 918208
Flags: in-testsuite+
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.