Develop API spec for RNA publication

RESOLVED DUPLICATE of bug 922381

Status

RESOLVED DUPLICATE of bug 922381
5 years ago
5 years ago

People

(Reporter: hoosteeno, Unassigned)

Tracking

Details

Attachments

(1 attachment)

Created attachment 802400 [details]
fxos_relnotes_v1.json

Once we have release notes in a Django application, we'll want to expose them so Bedrock can publish them. This will be a JSON API. In this bug, we'll discuss the endpoints that Bedrock will need, the parameters those endpoints will handle, and the data they'll return. We'll also probably talk about the technical implementation of this API.

Attached is a JSON file that was used to produce FxOS release notes v1.0. It's probably a useful jumping off point.
To clarify: The API will be served by Nucleus, consumed by Bedrock, populated by RNA.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922381
You need to log in before you can comment on or make changes to this bug.