add -runtime flag to stub to specify runtime

RESOLVED DUPLICATE of bug 1168737

Status

Firefox Graveyard
Webapp Runtime
P3
enhancement
RESOLVED DUPLICATE of bug 1168737
5 years ago
2 years ago

People

(Reporter: myk, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

(Reporter)

Description

5 years ago
The Mac app stub prefers to use the runtime with which it was installed, and it identifies it via its CFBundleIdentifier.  But the CFBundleIdentifier for custom builds of Firefox is the same as that for nightly builds: org.mozilla.nightly.

So if you have a regular nightly build in addition to a custom build, and you install an app with the custom build, then Mac OS X sometimes points the stub to the regular nightly build; which makes it cumbersome to test changes to the runtime that require testing against a custom build, since you have to throw away your nightly build, at least temporarily, to ensure your custom build is used.

To make such testing reliable, we need a way to point the stub to the specific custom build you want the app to use as its runtime.

smichaud and I talked it over in #macdev, and he would prefer to avoid giving custom builds a different CFBundleIdentifier, given the various issues we've previously encountered with the several CFBundleIdentifier values we already use (org.mozilla.firefox, org.mozilla.nightly, etc.), and since it raises the complex question of whether all custom builds should have the same CFBundleIdentifier or a unique one (and, if the latter, how to determine it).

So we should instead add a command-line flag to the stub that specifies the runtime to use, such that one can point the stub to a particular runtime when running it via the command line, i.e.:

  /path/to/app/Contents/MacOS/webapprt --runtime /path/to/objdir/dist/Nightly.app
See also bug 708459, "Implement mechanism for selecting which installed Firefox version will be loaded to run natively-installed webapp"
Priority: -- → P3
Blocks: 1111077
(Reporter)

Comment 2

3 years ago
I ended up implementing this over in bug 1168737.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Contact: myk
Resolution: --- → DUPLICATE
Summary: add --runtime flag to stub to specify runtime → add -runtime flag to stub to specify runtime
Duplicate of bug: 1168737
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.