/daily Graph and legend colors should match the colors chosen for the table headers in the Crashes per ADI table.

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: mbrandt, Assigned: Tchanders)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 802576 [details]
qa - screenshot of bug on stage

Graph colors/legend colors do not match product version colors in Crashes per ADI table. Note this is not a regression.

Steps to reproduce:
1. goto /daily and select several product versions

https://crash-stats.allizom.org/daily?form_selection=by_version&p=Firefox&v=23.0.1&v=24.0b&v=24.0b10&v=24.0b1&hang_type=any&os=Windows&os=Mac+OS+X&os=Linux&date_range_type=report&date_start=2013-08-27&date_end=2013-09-10&submit=Generate

https://crash-stats.mozilla.com/daily?form_selection=by_version&p=Firefox&v=24.0b1&v=26.0a1&v=24.0b&v=23.0.1&hang_type=any&os=Windows&os=Mac+OS+X&os=Linux&date_range_type=report&date_start=2013-08-27&date_end=2013-09-10&submit=Generate

Actual:
Graph colors/legend colors do not match product version colors in Crashes per ADI table.

Expected:
Graph and legend colors should match the colors chosen for the table headers in the Crashes per ADI table.
(Reporter)

Comment 1

4 years ago
Created attachment 802577 [details]
qa - screenshot of bug on prod

Additional screenshot of the bug on prod

Comment 2

4 years ago
isn't this a regression?  Or perhaps I've not been paying attention to graph labels + colors.
(Reporter)

Comment 3

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> isn't this a regression?  Or perhaps I've not been paying attention to graph
> labels + colors.

It may be a regression but I don't have the history behind this feature to know whether it is one or not.

Comment 4

4 years ago
Brandon has been working on this code recently.
Assignee: nobody → thalia.e.chan
Status: NEW → ASSIGNED
(Assignee)

Comment 5

2 years ago
This happens because the graph assigns colours to the versions once they've been sorted alphabetically, whereas the table does not. (The above images are from the old graph library but the same happens with the new graph library.)

A related problem is that when the same version is chosen twice in the form, the graph intelligently draws 3 lines and assigns 3 colours (instead of 4), but the table does not: it shows two copies of the repeated version and assigns each copy a different colour, so inevitably the colours in the graph and the table don't match. 

I suggest that the versions be sorted and made unique in the view. This will make the colours match and will prevent the table from having repeated columns.

Comment 6

2 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/f6b5633e95f6a5c015b2840a1082b1a604c8a2e7
Fixes Bug 914831 - /daily Graph and legend colors should match the colors chosen for the table headers

https://github.com/mozilla/socorro/commit/23d96e1b68eb5abfd1ed5faaf8932fd6ce8f92a9
Merge pull request #2919 from Tchanders/crashes-adi-versions

Fixes Bug 914831 - /daily Graph and legend colors should match the co…

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.