Closed Bug 914880 Opened 6 years ago Closed 6 years ago

mozharness change seems to have broken TBPL b2g18

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.1hd fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.1hd --- fixed

People

(Reporter: dhylands, Unassigned)

References

Details

So the b2g18 TBPL tree is closed due to some strange bustage. I took a look at the problem to help out RyanVM, and this is what I've discovered.

If we look at this commit:

https://tbpl.mozilla.org/?tree=Mozilla-B2g18&rev=796d0adce82b

On the "B2G ICS Emu Opt" line, the first green X comes from the first build, and the red X* and orange X's come from the second build, which was a retriggered build.

Looking at the build logs, the first build (green X) used a gaia commit of:
a7b8037f1f1bcafcfd5fbad7cd74f7e22bb80166

The second build, used a gaia commit of:
ef10d7ef19064e8f9a2f07b8e8d2a0ebe5dc1343

There are a total of 8 commits after the one that was successful:
ef10d7e Jose M. Cantera 9 hours ago Bug 907127 - [zffos1.1][Contacts][Import from Gmail] Not able to import ...(cherry picked from commit fed3a0f4eabef02a7af25b0
9466235 Andrew Sutherland 12 hours ago Merge pull request #12060 from asutherland/email-fix-embedded-v1
f73489a Andrew Sutherland 12 hours ago Bug 914493 - [Email] iframe is not resized for the embedded images that were already downloaded while building body. r=asu
6324c3b John Ford 2 days ago Merge pull request #11935 from dmarcos/master
cf27ccc John Ford 2 days ago Merge pull request #11903 from crdlc/bug-911875
914a7c7 John Ford 2 days ago Merge pull request #11200 from fabi1cazenave/cellBroadcastLabel-bug890151
2712456 John Ford 2 days ago Merge pull request #10992 from leob2g/Bug_894196_CB_msg_title_error
a6a0fb8 Timothy Guan-tin Chien 4 days ago Merge pull request #11712 from timdream/v1-train
a7b8037 Alive.Kuo 5 days ago Merge pull request #11974 from alivedise/bugzilla/897283_v1-train

So it's highly likely that one of these commits broke TBPL.

One of the following seems like the most likely candidate (the xpcshell test which is failing is dom/mobilmessage/tests/test_mms_pdu_helper.js)

ef10d7e (affects comms app)
914a7c7 (affects system app - seems to be related to cell broadcast)
2712456 (affects system app - seems to be related to cell broadcast)

The failure is that MMS_VERSION is undefined. I'm guessing that's happening because the code which defines it doesn't get executed due to some other error happening.
Note that this is keeping the b2g18 trees closed.
ef10d7e bug 907127
914a7c7 bug 890151
2712456 bug 894196

I've backed out the RIL related looking commits on v1-train to see if they are the problem.
Blocks: 907127, 890151, 894196
Backout commits: ef10d7e..4764cbc
The breakage seems to caused by a change in mozharness and not gaia.

In particular, this backout:
http://hg.mozilla.org/build/mozharness/rev/ebed70ba91c0

seems to have made xpcshell test go green again.

I'd like to restore the 3 commits that we backed out in gaia and retrigger just to be sure.
Summary: Gaia tree seems to have broken TBPL b2g18 → mozharness change seems to have broken TBPL b2g18
I've re-landed those commits.
I've retriggered another build. So this should just have the mozharness backout. If its green we can reopen the tree.
Green, reopened :-)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
v1.1.0hd: 4764cbcbdd39b68fc5c184b0eb40e9f43f0dde55
You need to log in before you can comment on or make changes to this bug.