[Marionette] It will make B2G screen broken with _select() in certain long list in FTU

RESOLVED DUPLICATE of bug 859264

Status

RESOLVED DUPLICATE of bug 859264
5 years ago
5 years ago

People

(Reporter: wachen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
When you start to test FTU by going thru the real FTU (not the FTU launched by settings app), if you try to use:

    def _select(self, match_string):
        self.marionette.switch_to_frame()

        options = self.marionette.find_elements(By.CSS_SELECTOR, '#value-selector-container li')
        close_button = self.marionette.find_element(By.CSS_SELECTOR, 'button.value-option-confirm')

        # Loop options until we find the match
        for li in options:
            if li.text == match_string:
                li.tap()
                break

        close_button.tap()

        # Now back to app
        self.marionette.switch_to_frame(self.app.frame)

when you try to select the country/city for time zone. The UI would be broken. For example, this does it. Just remember to select city out of the first few cities.

        city_select = self.marionette.find_element(*self._timezone_city_locator)
        city_select.tap()
        self._select("Taipei")
(Reporter)

Comment 2

5 years ago
Oh, yes, that's the same bug!!!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859264
You need to log in before you can comment on or make changes to this bug.