Closed Bug 915077 Opened 6 years ago Closed 6 years ago

Change the debug log level of HWC

Categories

(Core :: Graphics, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
blocking-b2g koi+
Tracking Status
firefox25 --- wontfix
firefox26 --- fixed
firefox27 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: mikeh, Assigned: pchang)

References

Details

Attachments

(1 file, 1 obsolete file)

I saw the following messages repeated in the logcat output of a hamachi while experiencing the problem in bug 796248:

09-11 06:14:09.240   144   264 D HWComposer: ContainerLayer Layer has planar semitransparency which is unsupported
09-11 06:14:09.240   144   264 D HWComposer: Render aborted. Nothing was drawn to the screen

After other delays and above messages appearing 158 times, the lockscreen (finally) appears.

These messages appear in other bugs: bug 881970 and bug 885345; not sure if all of these issues are related.

Observed in:
- gecko: m-c:729c5f06584a
- gaia: master:0fdc90c480de83e3acf57b734f0797751c900a28
Known issue, sotaro?
Flags: needinfo?(sotaro.ikeda.g)
I do not know about it. Added :pchang and :nical.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Mike Habicher [:mikeh] from comment #0)
> I saw the following messages repeated in the logcat output of a hamachi
> while experiencing the problem in bug 796248:
> 
> 09-11 06:14:09.240   144   264 D HWComposer: ContainerLayer Layer has planar
> semitransparency which is unsupported
> 09-11 06:14:09.240   144   264 D HWComposer: Render aborted. Nothing was
> drawn to the screen
> 
> After other delays and above messages appearing 158 times, the lockscreen
> (finally) appears.

These info just indicated that we didn't use HWC to compose screen because semitransparency layer existed.
It shouldn't case any problem. And it is easy to see this log during home scrolling.
Is this normal and expected behaviour? If so, do we need to log these items?
Flags: needinfo?(pchang)
(In reply to Mike Habicher [:mikeh] from comment #5)
> Is this normal and expected behaviour? If so, do we need to log these items?

They are at:
http://dxr.mozilla.org/mozilla-central/source/widget/gonk/HwcComposer2D.cpp#l138
Layer has planar semitransparency which is unsupported

http://dxr.mozilla.org/mozilla-central/source/widget/gonk/HwcComposer2D.cpp#l428
Render aborted. Nothing was drawn to the screen


Currently we can not use hwc to compose semitransparent layer.
When one layer is semitransparent, all layers will fall back to gpu composition.
(call PrepareLayerList() failed and show "render aborted")
I think it's normal behavior.
Flags: needinfo?(pchang)
Summary: "ContainerLayer Layer has planar semitransparency which is unsupported" / "Render aborted. Nothing was drawn to the screen" → Change the debug log level of HWC
Attached patch change the debug level of HWC (obsolete) — Splinter Review
There are too many HWC debug logs with a release build. Output the detail HWC debug only HWC_DEBUG is true.
Assignee: nobody → pchang
Attachment #805210 - Flags: review?(ncameron)
Comment on attachment 805210 [details] [diff] [review]
change the debug level of HWC

Review of attachment 805210 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with typo fixed and a comment

::: widget/gonk/HwcComposer2D.cpp
@@ +32,5 @@
>  #endif
>  
>  #define LOG_TAG "HWComposer"
>  
> +//#define HWC_DEBG

missing U

And please add a comment above the comment stating when you would want to uncomment this line.
Attachment #805210 - Flags: review?(ncameron) → review+
Fix type error and add comment for hwc debug message behavior changes.
Attachment #805210 - Attachment is obsolete: true
Attachment #805770 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/454f59631b74
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Duplicate of this bug: 923669
Without this patch there is a lot of spam in v1.2.
blocking-b2g: 1.3? → koi?
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.