Closed Bug 915114 Opened 9 years ago Closed 9 years ago

SMS notification is not invoked sooner then the phone is unlocked

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

Other
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 913777

People

(Reporter: mayhemer, Unassigned)

Details

Unagi, 1.1.0.0-prerelease, nice, platform version 18.1, build ID 20130908041201, gaia git commit a6a0fb8492... (2013-09-07 05:28:28)

but I've hit this even on older revisions.  No idea on any regression range :(

I'm on Vodafone Czech Republic, Prague.

Scenario:
- let the phone be on good and strong signal
- let the phone be connected to a wifi (home)
- leave it as is (i.e. locked in standby)
- someone sends you an SMS

Actual behavior:
- sometimes (<~20% of cases) the notification is arisen not when actually received from the GSM network, but right at the moment I unlock the phone (with the top power button).  Right at the moment means really "right at the moment", there is not any even 100ms delay noticeable.  So, it doesn't seem like the phone would not be receiving message from the operator, but like it's not able to wake-up and do the notification (sound + UI message).

Expected:
- obviously, get the notification instantly


Maybe this is already fixed on the Nightly channel, but I was not able to change the channel so far.  Even though the phone says "Update channel: nightly" I'm still on 18.1.  Or is that alright and I'm on Nightly?


Marking critical, since this cost me some trouble (and also money loss!) already and it's a major bug.
Hey Honza,

I think this was fixed yesterday in bug 913777.

Unfortunately it won't be in the 1.1 version but in the 1.2 version.

I agree with you it's something major, bug 913777 was asked leo? so maybe it will be uplifted to 1.1... but I don't count on it.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Thanks Julien.
You need to log in before you can comment on or make changes to this bug.