If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent - swipping a process away fails to move the card away

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 803011 [details]
Logcat

Build: Master 9/10/2013
Device: Unagi

I'm seeing the task card failing to swipe away intermittently.

Example STR where this has happened below.

1. Go to http://mozilla.github.io/qa-testcase-data/webapi/mediarecorder/index.html
2. Select setup
3. Select play on both media controls that appear
4. Select start recording
5. Long press home button
6. Try to kill the browser app process

Expected

The browser app process should be killed.

Actual

Intermittently, the app process won't disappear. Logcat also shows:

09-11 15:40:37.675: E/GeckoConsole(110): [JavaScript Error: "currentCard.addEventListener is not a function" {file: "app://system.gaiamobile.org/js/cards_view.js" line: 542}]
(Reporter)

Updated

4 years ago
blocking-b2g: --- → koi?
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
QA Contact: sparsons

Comment 1

4 years ago
I was able to reproduce this issue as far back as the 8/10 on the 1.2 Buri and Unagi Build
ID:20130810040220

Environmental Variables
Build ID: 20130810040220
Gecko: http://hg.mozilla.org/mozilla-central/rev/c5946a8bcd5b
Gaia: 2814f1df7dd77590250aef0035704e60428765ff
Platform Version: 26.0a1

App process will not disappear intermittently.
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

4 years ago
Can you find out if this reproduces on 1.1 & 1.01?
Keywords: qawanted

Comment 3

4 years ago
I was unable to reproduce on 9/06 1.0.1 Build ID: 20130906043205

Environmental Variables
Build ID: 20130906043205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 054cdc27404e2daca91d3065d9783681032b2151
Platform Version: 18.0

Also unable to reproduce on 9/13 Leo Comm / Moz Ril Build ID: 20130913041203

Environmental Variables
Build ID: 20130913041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/091fcf40d427
Gaia: f7afca06d02ee34fcd82eb0020eb2162e5045ee7
Platform Version: 18.1
RIL Version: 01.01.00.019.222
Keywords: qawanted
(Reporter)

Comment 4

4 years ago
Okay - so this is definitely a regression, but it's present in a build farther back than 8/10/2013. We also saw this issue during the Oslo demos, so there's definitely people hitting this.

Can we try going farther back than 8/10/2013 to get a regression window?
Keywords: regressionwindow-wanted

Comment 5

4 years ago
Last working on 8/09 1.2 Build ID: 20130809040201

Environmental Variables
Build ID: 20130809040201
Gecko: http://hg.mozilla.org/mozilla-central/rev/e33c2011643e
Gaia: c354940fbe112bcf2d90e2a5654ad1824f3a2348
Platform Version: 26.0a1
RIL Version: 01.02.00.019.043 

First failing on 8/10 1.2 Build ID:20130810040220

Environmental Variables
Build ID: 20130810040220
Gecko: http://hg.mozilla.org/mozilla-central/rev/c5946a8bcd5b
Gaia: 2814f1df7dd77590250aef0035704e60428765ff
Platform Version: 26.0a1
Keywords: regressionwindow-wanted
Whiteboard: [FT:System-Platform]
Not a FT:System-Platform bug.
Flags: needinfo?(anygregor)
Whiteboard: [FT:System-Platform]
(Reporter)

Comment 7

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #6)
> Not a FT:System-Platform bug.

Why? Isn't this a cards view bug?
blocking-b2g: koi? → koi+
Flags: needinfo?(anygregor)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 931514
Whiteboard: [systemsfe]
I'm not sure the JS Error is related to our failure to kill the process yet. I am able to reproduce that JS error whenever I swipe anywhere on an empty cards view screen, or when I am swiping away the last card in cards view (but interestingly not when I use the 'X' button).

In any case, this issue is hard to track down since I've only been able to reproduce it once. Most likely, we will want to fix the JS issue separately, but I want to investigate further before reopening bug 931514.
Jason, can you help me reproduce this?

Using an unagi device on Build ID: 20131031004003 I tried to repro using the steps in comment 1 about 10 times, but was unable to. Should I just keep trying?

Also, is it that the card just won't go away when you swipe up, or is it that the process sticks around after successfully swiping it away? If the former, are you able to close the app with the 'X'?
Flags: needinfo?(jsmith)
(Reporter)

Comment 11

4 years ago
QA Wanted on comment 10 - Can someone look into seeing if this still reproduces, how often it reproduces, and the STR used to reproduce it?
Flags: needinfo?(jsmith)
Keywords: qawanted

Comment 12

4 years ago
This issue does not reproduce on the Buri 1.2 Build ID: 20131031004003

Gaia   df049e3177ced0ca493ff0d192c65f18392bb462
SourceStamp 93eafd042c1c
BuildID 20131031004003
Version 26.0
Keywords: qawanted
(Reporter)

Comment 13

4 years ago
Sounds like this original issue was fixed (the original issue reproduced at a fairly significant rate), although I don't know what fixed it. I'll mark this wfm & reopen the dupe to track fixing the JS error.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.