The load time for urls with frames is incorrect

VERIFIED FIXED in M8

Status

P3
blocker
VERIFIED FIXED
20 years ago
2 years ago

People

(Reporter: pawyskoczka, Assigned: law)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf], URL)

(Reporter)

Description

20 years ago
Overview Description:
The load time for the following url http://www.netcom.com is way out of bounds.
This is affecting our performance testing, since the averages for the 100 url
test is misleading.   The time reported is much greater than the actual time.

Steps to Reproduce:
1) Launch the browser
2) Load the following url http://www.netcom.com
3) After the load is complete, check the console for the load time
4) The time is Document: Done (930866245.317 secs)


Actual Results:
Document http://www.netcom.com/ loaded successfully
Document: Done (930866245.317 secs)

Expected Results:
Document http://www.netcom.com/ loaded successfully
Document: Done (2.317 secs) <-- Something along these lines

Build Date & Platform Bug Found:
1999063008 -- Win32

Additional Builds and Platforms Tested On:
-Appears to be only on Windows; Linux is ok.

Additional Information:
Important for performance testing

Updated

20 years ago
Assignee: don → law
Severity: critical → blocker
Component: Browser-General → other
QA Contact: leger → vstevens
Target Milestone: M8

Comment 1

20 years ago
law - assigning to you since Bindu gave you the heads up on this and you are
familiar with the problem.  This is blocking automated smoke tests.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

20 years ago
I'm looking at it.  Looks like some JS or timing quirk, although netlib is
shifting under our feet a bit...

Updated

20 years ago
Whiteboard: [Perf]
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

20 years ago
I added code to navigator.js to avoid setting "document done" when it shouldn't
be set.

This should solve the problem reported here (breaking performance tests).

There are still problems with download progress and status bar messages.  Those
are being addressed per a different bug, bug #8705.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Will mark this Verified and track problem in new bug.  Thanks law!
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.