Change configuration of external/caf/kernel/msm.git

RESOLVED WONTFIX

Status

Developer Services
General
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: catlee, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Bug 857158 keeps bothering me.

I found this stackoverflow answer that I'd like to try out:
http://stackoverflow.com/questions/17683295/git-bash-error-rpc-failed-result-18-htp-code-200b-1kib-s

I think the last solution has an interesting idea: reduce the size of postBuffer on the _server_.

I can reproduce the failure in bug 857158 current in the http://git.mozilla.org/external/caf/kernel/msm.git repository, so can we try adjusting the postBuffer size there?

The cmdline I'm using is:
git clone --quiet http://git.mozilla.org/external/caf/kernel/msm.git
error: RPC failed; result=18, HTTP code = 200
fatal: The remote end hung up unexpectedly
fatal: protocol error: bad pack header
(Reporter)

Updated

5 years ago
Depends on: 857158
(Reporter)

Updated

5 years ago
Blocks: 857158
No longer depends on: 857158
So, the man page for git-config states the default for http.postBuffer is 1MiB, while that stackoverflow article seems to be setting it to ~23MiB. Or I'm bad at math. :-)

Regardless, setting it to their suggested value or to 0.9MiB results in the same error:

git1.dmz.scl3# cat msm.git/config 
[core]
	repositoryformatversion = 0
	filemode = true
	bare = true
[http]
	postBuffer = 943718

sekrit$ git clone -q http://git.mozilla.org/external/caf/kernel/msm.git
error: RPC failed; result=18, HTTP code = 200
fatal: The remote end hung up unexpectedly
fatal: protocol error: bad pack header

I'm trying to see what's happening on the wire, to see if it's similar to the issue preventing try from being cloned via http, but instead I'm getting one chunk and then git seems to hang, doing nothing; not useful! 

For the time being, I've reverted the repo to its original state.
Wontfixing, as this didn't work as expected and appears to be sorted by changing the apache timeout (857158#c9).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Component: WebOps: Source Control → General
Product: Infrastructure & Operations → Developer Services
You need to log in before you can comment on or make changes to this bug.