Thunderbird hangs then resumes when viewing GMail over IMAP

RESOLVED DUPLICATE of bug 912216

Status

Thunderbird
Untriaged
--
major
RESOLVED DUPLICATE of bug 912216
5 years ago
5 years ago

People

(Reporter: Jon, Unassigned)

Tracking

({perf})

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130903162616

Steps to reproduce:

I use Thunderbird to connect to two accounts. Both accounts are GMail accounts over IMAP.

Thunderbird frequently hangs for several seconds (~10s maybe more) when doing normal opertations. These operations include clicking and viewing different folders, clicking and viewing different mails, and (most annoyingly) composing new mails.

Occasionally when this happens a dialog appears to quit Thunderbird. If I click "wait" Thunderbird will eventually resume.

This happens several times a day. I can't reproduce this at will, but it happens frequently enough that it is a regular occurance.

My expectation is for a smooth experience with no (or little) interruption. 

I am using Fedora 19 and Thunderbird 17.0.8 as packaged by Fedora.

Comment 1

5 years ago
Did this start happening recently?
Can you try starting TB in safe mode (Help->restart with addons disabled)? To see if any addon may be causing it.

Or it is the CONDSTORE support of Gmail, see bug 912216.
(Reporter)

Comment 2

5 years ago
> Did this start happening recently?

I only started using Thunderbird recently so I do not know.

> Can you try starting TB in safe mode (Help->restart with addons disabled)? To see if any addon may be causing it.

I do not use any addons. Is this test still necessary?

> Or it is the CONDSTORE support of Gmail, see bug 912216.

Not sure. If I change mail.server.default.use_condstore to false, is that enough to conduct a test? I'll make this change and experiment for some time and report back if this helps.

Comment 3

5 years ago
(In reply to Jon from comment #2)
> > Or it is the CONDSTORE support of Gmail, see bug 912216.
>
> I'll make this change and experiment for some time
> and report back if this helps.

report back both if it helps or doesn't. thanks
Severity: normal → major
Flags: needinfo?(jon.dufresne)
Keywords: perf
(Reporter)

Comment 4

5 years ago
> report back both if it helps or doesn't. thanks

After changing the CONDSTORE setting, I have not experienced the same performance issues. Should we conclude this is a duplicate?
Flags: needinfo?(jon.dufresne)

Comment 5

5 years ago
You can try it for several days. Then you can try setting the preference back if the problem reappears. If you are sure that the preference fixes the problem for you you can duplicate the bug, thanks.

Updated

5 years ago
Flags: needinfo?(jon.dufresne)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jon.dufresne)
Resolution: --- → DUPLICATE
Duplicate of bug: 912216
You need to log in before you can comment on or make changes to this bug.