Need offline cache in OCSP code.

RESOLVED DUPLICATE of bug 48597

Status

NSS
Libraries
P2
enhancement
RESOLVED DUPLICATE of bug 48597
16 years ago
14 years ago

People

(Reporter: Javier Delgadillo, Assigned: Julien Pierre)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Customers have asked for PSM to provide an off-line cache of OCSP responses. 
PSM can't do that until NSS provides caching of OCSP responses.
(Reporter)

Updated

16 years ago
Blocks: 48597

Comment 1

16 years ago
Assigned the RFE to Julien.
Assignee: wtc → jpierre
(Assignee)

Updated

16 years ago
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → 4.0

Comment 2

15 years ago
Changed the QA contact to Bishakha.
QA Contact: sonja.mirtitsch → bishakhabanerjee

Comment 3

15 years ago
Dupe of bug 48597?

Comment 4

15 years ago
Bug 48597 is not a duplicate of this bug but
rather a PSM bug that depends on this NSS bug.

Comment 5

14 years ago
An offline cache requires storing the OCSP responses in
persistent storage.  The design and implementation of
the persistence is complicated.  A simpler OCSP cache
that can't be used offline or across application sessions
is still useful because it could improve performance by
reducing the number of OCSP responses that need to go
to the network.  At the NSS OCSP meeting on May 1, we
decided that the simpler, non-offline OCSP cache could
be implemented first, and so it has been filed as bug
205406.
(Assignee)

Comment 6

14 years ago
FYI, the offline cache could use code from the simpler online cache, so I'm
adding a dependency to bug 205406.
Depends on: 205406

Updated

14 years ago
Blocks: 110166

Updated

14 years ago
No longer depends on: 205406

Updated

14 years ago
Depends on: 205406
No longer blocks: 110166
This bug is simply a dupe of 48597.  

*** This bug has been marked as a duplicate of 48597 ***
No longer blocks: 48597
Status: NEW → RESOLVED
Last Resolved: 14 years ago
No longer depends on: 205406
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.