wrong bug moved between columns -- possibly only when page filter active

RESOLVED FIXED

Status

Webtools
kanbanzilla
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: hwine, Assigned: Derek Ries)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I have a board created on prod:release engineering, comp:other

I filtered the "backlog" using "sheriff" to locate bug 914877, then drug that ticket to the "needs investigation" column. I then opened the bug, and updated it. (I was surprised to see no whiteboard data in the bug at that time.) The bug remained displayed in the "needs investigation" column.

I reopened the board in another window later, and found only bug 794216 in the "needs investigation" column. In reviewing that bug, I see that "I" updated the whiteboard of that bug at the time I was moving bug 914877.

I note that, on a fresh load of the board, bug 794216 is first displayed. After filtering for "sheriff", bug 914877 is first display.
(Assignee)

Comment 1

4 years ago
I see, the problem is that jquery-ui sortable tries to remake the object using the index of the filtered array into the non-filtered array. Should be able to get the object manually rather than relying on them to provide the right one.
(Assignee)

Updated

4 years ago
Whiteboard: kanbanzilla[Needs Investigation]
(Assignee)

Updated

4 years ago
Assignee: nobody → dries
Status: NEW → ASSIGNED
Whiteboard: kanbanzilla[Needs Investigation]
(Assignee)

Comment 2

4 years ago
Ok, this should be fixed in the newest build (not yet deployed).
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.