Private browsing does not return to the corrent URL

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Alex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31

Steps to reproduce:

Open a private browsing tab, enter a URL, say X.

Do some browsing, changing the current url to Y.

After some time (are the tabs unloaded? activity sleeping or something?) if you return to the tab, X is loaded and not Y.


Actual results:

X, the original url was reloaded in the tab.


Expected results:

Y, the last url, should have been reloaded in the tab.
Which device, OS and version of Firefox are you using? This works for me fine on my Nexus 4 (Android 4.3) and Galaxy SIV (Android 4.3) running Fx24, Fx25, Fx26. I left the devices idles for ~15 minutes and returned to the same tab open as left them and not an originating tab from the session. I don't see the relationship to Private Browsing here. Can you try using regular-tabs? Also do you see this on Nightly (http://nightly.mozilla.org)?
(Reporter)

Comment 2

5 years ago
I'm on a Nexus 4 running 4.3, running the stable/regular version from the app store. It happens only overnight - in the morning all my private tabs "reset" to X. It doesn't seem to happen during the day, where I access it every few hours. I'll try to pay attention to my regular tabs tomorrow morning too.

For comparison, Chrome Mobile never lost the current tabs EXCEPT after an update (or reboot) has been applied.
Brian?
Flags: needinfo?(bnicholson)
Usually these "wait awhile and come back to the phone" bugs are about Firefox being killed in the background, then restored when Firefox is reopened. You can force these conditions manually by installing https://hg.mozilla.org/users/blassey_mozilla.com/oom-fennec/ to your phone's /data/local/tmp/ directory, then executing it using adb shell. That said, I'm not able to reproduce this.

Here's what I'm trying:
1) Open Firefox, then open a private browsing tab
2) Search "mozilla" in the private tab
3) Click the first link to go to www.mozilla.org/en-US/
4) Push home, then run oom-fennec to force Firefox to be background killed
5) Reopen Firefox

As expected, Firefox restores the last tabs and opens www.mozilla.org/en-US/.
Flags: needinfo?(bnicholson)
(Reporter)

Comment 5

5 years ago
I didn't try your tool, but it's definitely a reproducible (in how I described it) issue for me.

Perhaps firefox isn't going to the completely dead state but some of the other states that an android Activity can go through... I don't know, I'm just reporting the issue :)
Is this still an issue?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ademko)
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

4 years ago
Seems to work now, I've been testing it for the past week.

Thanks, I can switch to firefox again.
Flags: needinfo?(ademko)
You need to log in before you can comment on or make changes to this bug.