Closed Bug 915571 Opened 7 years ago Closed 7 years ago

Thunderbird fails to compile nsldif32v60.dll: LINK : fatal error LNK1104: cannot open file 'mozcrt.lib'

Categories

(Thunderbird :: Build Config, defect)

All
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 26.0

People

(Reporter: mcsmurf, Assigned: jcranmer)

Details

(Keywords: regression)

Currently the Thunderbird trunk build fails on Windows with this error:

======= making ./nsldif32v60.dll
e:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\objdir-tb\ldap\sdks\c-sdk\ldap\libraries\libldif\Makefile:143:0$ lib -NOLOGO -OUT:"nsldif32v60.lib" ./line64.obj 
e:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\objdir-tb\ldap\sdks\c-sdk\ldap\libraries\libldif\Makefile:152:0$ link -LIBPATH:e:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/objdir-tb/mozilla/dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcrtd -NODEFAULTLIB:msvcprt -NODEFAULTLIB:msvcprtd -DEFAULTLIB:mozcrt -DYNAMICBASE -OUT:"nsldif32v60.dll" -DEBUG -OPT:REF -MAP -nologo -DLL -SUBSYSTEM:WINDOWS  -SUBSYSTEM:CONSOLE    -out:"nsldif32v60.dll" ./line64.obj  -DEF:e:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/ldap/sdks/c-sdk/ldap/libraries/msdos/winsock/nsldif32.def  
LINK : fatal error LNK1104: cannot open file 'mozcrt.lib'
e:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\objdir-tb\ldap\sdks\c-sdk\ldap\libraries\libldif\Makefile:152:0: command 'link -LIBPATH:e:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/objdir-tb/mozilla/dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcrtd -NODEFAULTLIB:msvcprt -NODEFAULTLIB:msvcprtd -DEFAULTLIB:mozcrt -DYNAMICBASE -OUT:"nsldif32v60.dll" -DEBUG -OPT:REF -MAP -nologo -DLL -SUBSYSTEM:WINDOWS  -SUBSYSTEM:CONSOLE    -out:"nsldif32v60.dll" ./line64.obj  -DEF:e:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/ldap/sdks/c-sdk/ldap/libraries/msdos/winsock/nsldif32.def  ' failed, return code 1104
<export>: Found error

Full build log at https://tbpl.mozilla.org/php/getParsedLog.php?id=27696785&full=1&branch=comm-central
Keywords: regression
So maybe a fix similar to Bug 913968 is needed (don't link to mozcrt during export)?
Summary: Thunerbird fails to compile nsldif32v60.dll: LINK : fatal error LNK1104: cannot open file 'mozcrt.lib' → Thunderbird fails to compile nsldif32v60.dll: LINK : fatal error LNK1104: cannot open file 'mozcrt.lib'
Looks like https://hg.mozilla.org/comm-central/rev/303c7574e706 fixed this :)
Assignee: nobody → Pidgeot18
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
You need to log in before you can comment on or make changes to this bug.