If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

canceling the awesome page does not allow focus back into the content

RESOLVED FIXED

Status

Firefox OS
Gaia::Browser
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nhirata, Assigned: kanru)

Tracking

(Blocks: 1 bug, {qablocker})

unspecified
ARM
Gonk (Firefox OS)
qablocker

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [sprintready][systemsfe])

Attachments

(1 attachment)

try build:
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/try-builds/blassey@mozilla.com-1e0c76686a0a/try-unagi/:
remote="hgmozillaorg" revision="1e0c76686a0a"
remote="mozillaorg" revision="a278506e2133cb14c249f15e42f99eadb242d1b8"
Unagi

STR:
1. go to http://people.mozilla.com/~nhirata/html_tp/formsninput.html
2. tap on the url bar
3. delete the url
4. hit the cancel button
5. try to tap in a text field in the content

Expected: text field gets focus
actual: nothing happens

Note: 
1. Does not happen on buri : 9/10 build
2. http://www.youtube.com/watch?v=_EpMtx3K2R0&feature=youtube_gdata_player
Summary: deleting the URL from the URL bar does not allow focus back into the content → [trybuild] deleting the URL from the URL bar does not allow focus back into the content
Also occurs : 
https://git.mozilla.org/releases/gecko.git
Gecko c56811a63fd7dfdab9d48c9cb14358e0e605ca56
Gaia   59e172cecef27cd0792c7da3ffbf87973be8f706
BuildID 20130912165356
Version 26.0a1
Buri
Severity: normal → major
blocking-b2g: --- → koi?
Summary: [trybuild] deleting the URL from the URL bar does not allow focus back into the content → deleting the URL from the URL bar does not allow focus back into the content
Turns out you don't need to do step 3.
Summary: deleting the URL from the URL bar does not allow focus back into the content → canceling the awesome page does not allow focus back into the content
Keywords: qablocker
blocking-b2g: koi? → koi+
Whiteboard: [sprintready]

Comment 3

4 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/57245806
Whiteboard: [sprintready] → [sprintready][systemsfe]
It seems like the device just lost network connectivity and was in offline mode.

Please re-open if this is consistently reproduceable and other web sites load.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Ooops, commented on wrong bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
This works if you press the power button and unlock the phone again.
I think this is a gaia issue.
Or maybe not a gaia issue...
Kanru, are you familiar with the dom parts of browser-element? Can you check the flow here when we cancel the awesome page? I think we are missing a visibility event somewhere.
Flags: needinfo?(kchen)
(Assignee)

Comment 8

4 years ago
Created attachment 818870 [details] [diff] [review]
Hide current tab before display the awesome screen

Interesting.. If I set the current page to invisible before display the awesome screen then it this bug does not occur.
Flags: needinfo?(kchen)
Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412

(In reply to Kan-Ru Chen [:kanru] from comment #8)
> Created attachment 818870 [details] [diff] [review]
> Hide current tab before display the awesome screen
> 
> Interesting.. If I set the current page to invisible before display the
> awesome screen then it this bug does not occur.
(Assignee)

Comment 10

4 years ago
(In reply to Alive Kuo [:alive] from comment #9)
> Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412

Do you mean the browser was not focused? Is this a gaia issue?
It's focused I think, but only revert visibility again fix the issue.
(In reply to Kan-Ru Chen [:kanru] from comment #10)
> (In reply to Alive Kuo [:alive] from comment #9)
> > Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412
> 
> Do you mean the browser was not focused? Is this a gaia issue?

Not a gaia bug, this is just a workaround.
(Assignee)

Comment 13

4 years ago
(In reply to Alive Kuo [:alive] from comment #12)
> (In reply to Kan-Ru Chen [:kanru] from comment #10)
> > (In reply to Alive Kuo [:alive] from comment #9)
> > > Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412
> > 
> > Do you mean the browser was not focused? Is this a gaia issue?
> 
> Not a gaia bug, this is just a workaround.

OK. Still needs to find the root cause then.
This is a wild guess, but could this be a regression in Gecko caused by http://hg.mozilla.org/mozilla-central/rev/20b30db87bf4 ?

Or did I break it in Gaia when I refactored the awesomescreen? I can't see any manual visibility changes that I missed...
Flags: needinfo?(kchen)
(In reply to Kan-Ru Chen [:kanru] from comment #13)
> (In reply to Alive Kuo [:alive] from comment #12)
> > (In reply to Kan-Ru Chen [:kanru] from comment #10)
> > > (In reply to Alive Kuo [:alive] from comment #9)
> > > > Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412
> > > 
> > > Do you mean the browser was not focused? Is this a gaia issue?
> > 
> > Not a gaia bug, this is just a workaround.
> 
> OK. Still needs to find the root cause then.

Should we take this workaround for 1.2 and file a followup bug that might or might not make it to 1.2 depending on your availability to debug?
(Assignee)

Comment 16

4 years ago
(In reply to Gregor Wagner [:gwagner] from comment #15)
> (In reply to Kan-Ru Chen [:kanru] from comment #13)
> > (In reply to Alive Kuo [:alive] from comment #12)
> > > (In reply to Kan-Ru Chen [:kanru] from comment #10)
> > > > (In reply to Alive Kuo [:alive] from comment #9)
> > > > > Yes, that's what I did in https://bugzilla.mozilla.org/show_bug.cgi?id=914412
> > > > 
> > > > Do you mean the browser was not focused? Is this a gaia issue?
> > > 
> > > Not a gaia bug, this is just a workaround.
> > 
> > OK. Still needs to find the root cause then.
> 
> Should we take this workaround for 1.2 and file a followup bug that might or
> might not make it to 1.2 depending on your availability to debug?

I think we should take this workaround first. I might be able to debug this more in one or two days but it not clear where the problem is currently.

(In reply to Ben Francis [:benfrancis] from comment #14)
> This is a wild guess, but could this be a regression in Gecko caused by
> http://hg.mozilla.org/mozilla-central/rev/20b30db87bf4 ?
> 
> Or did I break it in Gaia when I refactored the awesomescreen? I can't see
> any manual visibility changes that I missed...

It doesn't look like you break it in the refactoring because the old version is broken too.
Flags: needinfo?(kchen)
I would really prefer to fix the underlying Gecko regression, but if we have to take this workaround then please flag me for review.
Comment on attachment 818870 [details] [diff] [review]
Hide current tab before display the awesome screen

Lets get this started :)
Attachment #818870 - Flags: review?(bfrancis)
Blocks: 930046
Attachment #818870 - Flags: review?(bfrancis) → review+
https://github.com/mozilla-b2g/gaia/commit/ed6b6eb15c025b8dfe05c89b42da8159ec3a7024
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Assignee: nobody → kchen
Uplifted ed6b6eb15c025b8dfe05c89b42da8159ec3a7024 to:
v1.2: befc189870bab77d5974f05d644f73f4d3a7e24f
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.