imap doest fetch mail INBOX destroyed

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: giluxxx, Unassigned)

Tracking

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130820153654

Steps to reproduce:

last week suddenly all (imap) mails where gone in one account except for 300 or so.. the account had at least 20000 messages in it

the messages that are still in there ranging from 2010-2013 so its not like it deleted a certain date range

then a week later the exact same problem with another account

the INBOX file was still there however, about 1.2GB

then i tried the repair option.. this resulted in a an empty window... right clicking the window results in some sort of artefact that looks like a 'star', a sort of fading cross like a plus sign but bigger

then i noticed the INBOX file suddenly was gone altogether?!

now this same thing happens on another pc, but this is a fedora 17 pc where the other is fedora 18 (thunderbird-17.0.8-1.fc18.x86_64)

i made a copy of the INBOX from another pc which had a subscription to this account and deleted all msf files and such.. moving it into the account result in empty messages screen

i finally used the importexport extention to import the backup INBOX file to 'Local Folders' folder (since importexport cant import to imap account)... so i guess the INBOX isnt corrupted... it also looks just fine when viewing the contents

then i tried to disable the account and create a second one.

it starts syncing over imap.... but only those same 300 messages.

if i delete a message, it disappears to only re-appear like 2 seconds later... 
if i move a message into the folder it gets expunged immediately again..

also it wont fetch any new mails...

it seems like it's locked.. or synchronizes with a ghost server...

if i go into the webmail client all seems fine and dandy..

too wierd...

my guess it's a linux version specific issue..


honestly, i must admit, it looks a bit like the same problem that happens very rarely where thunderbird suddenly forgets its subscribed to a certain folder and the folder seems empty.

usually thats easily solved by just ticking the subscribe box again for that specific folder and it starts downloading again...

what seems to be happening is like a severe instance of this behaviour...

ive seen it (loosing a subscription) happen on windows an less frequently on linux.

maybe if this happens when 2 clients are connecting from different locations to the same imap account and one looses its subscription while syncing all hell breaks loose.. because the other will not know what's going on.. just a wild guess

maybe someone can tell me where to begin to debug this.. the error console doesnt reveal anything interesting


Actual results:

i didnt do anything,
ive been using thunderbird for almost 10 years now and now this happens


Expected results:

mail should have been there
(Reporter)

Comment 1

5 years ago
all of the suddenly mail started pooring in again after a week... still no idea what happened.. maybe server was the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.