Tracking flags don't contain values

RESOLVED FIXED

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: erik.bryn, Assigned: dkl)

Tracking

Development

Details

(Reporter)

Description

5 years ago
The `values` array of tracking flags is empty. For example: https://bugzilla-dev.allizom.org/rest/ember/show/843627. The `tracking-firefox22` field should have a `?` value, as can be seen in the existing interface: https://bugzilla-dev.allizom.org/show_bug.cgi?id=843627

Also, how are tracking flags being grouped together in the existing interface?
(Reporter)

Comment 1

5 years ago
More details: the fields have `can_edit` as false, which is probably why `values` is empty, but I am able to set the `?` flag in the existing interface.
(Assignee)

Comment 2

5 years ago
Fixed some issues with both the TrackingFlags implementation and the new Ember extension as well.
Please give it a try now and file a new bug if this is still a problem.

dkl

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2
modified extensions/TrackingFlags/Extension.pm
modified extensions/TrackingFlags/lib/Flag.pm
Committed revision 9000. 

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2-dev
modified extensions/Ember/lib/WebService.pm
modified extensions/TrackingFlags/Extension.pm
modified extensions/TrackingFlags/lib/Flag.pm
Committed revision 8547.
Assignee: nobody → dkl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
(Reporter)

Comment 3

5 years ago
I'm seeing values now, but I'm seeing more values than I should (due to permissions). For example, `tracking-firefox24` shows me only a `?` value in the existing Bugzilla UI, but the API returns `?`, `+`, and `-`. If I try to set those values using the Bug.update API, I get a permission error.
(In reply to Erik Bryn from comment #3)
> I'm seeing values now

from irc it looks like the issue was bugzilla-dev needed updating.
closing bug again.

>  but I'm seeing more values than I should (due to
> permissions). For example, `tracking-firefox24` shows me only a `?` value in
> the existing Bugzilla UI, but the API returns `?`, `+`, and `-`. If I try to
> set those values using the Bug.update API, I get a permission error.

please file a new bug for different issues, especially ones that have already been committed.
i've created bug 930376 to track that issue.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.