Closed Bug 915835 Opened 8 years ago Closed 7 years ago

fix event listener leak in socialmark xbl handler

Categories

(Firefox Graveyard :: SocialAPI, defect)

26 Branch
x86
macOS
defect
Not set
normal

Tracking

(firefox28 unaffected, firefox29+ fixed, firefox30 fixed)

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 --- unaffected
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: mixedpuppy, Assigned: mixedpuppy)

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

The load eventlistener is not released due to use of bind()
Attached patch fix event handler leak (obsolete) — Splinter Review
Assignee: nobody → mixedpuppy
Attachment #803923 - Flags: review?(felipc)
Attachment #803923 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/7b346620c743
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
I regressed this fix in bug 940155 and didn't discover it until now in 29 (Australis).  New fix coming...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This will need uplift to 29 as well.
Attachment #803923 - Attachment is obsolete: true
Attachment #8390918 - Flags: review?(mhammond)
Attachment #8390918 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/mozilla-central/rev/c425c825c08b
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Comment on attachment 8390918 [details] [diff] [review]
event handler fixes

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 940155
User impact if declined: users of a soon-to-be-released-for-fx28 provider will experience some broken behavior due to repeated/invalid events caused by the leak
Testing completed (on m-c, etc.): fx-team and m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8390918 - Flags: approval-mozilla-aurora?
Attachment #8390918 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8390918 [details] [diff] [review]
event handler fixes

This got approved but not landed before beta 29 uplift, request beta approval now so it can land early there.  I've verified the fix in fx30.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 940155
User impact if declined: users of a soon-to-be-released-for-fx28 provider will experience some broken behavior due to repeated/invalid events caused by the leak
Testing completed (on m-c, etc.): fx-team and m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8390918 - Flags: approval-mozilla-beta?
Attachment #8390918 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Target Milestone: Firefox 26 → Firefox 30
QA Whiteboard: [qa-]
Whiteboard: [qa-]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.